System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

install/boot sles10 from san

joseph pareti
Frequent Advisor

install/boot sles10 from san

I want to create a boot device on an MSA1500 for sles10/xen, so that I can boot a proliant connected to it. (the internal disk of the proliant contains a rhel 4 boot, so it should not be touched).

I have tried to follow the UG
"HP StorageWorks booting Linux x86 from a san app notes" (october 2007), however I have the following problem/questions:

1. how do I assign a bootable LUN
2. how do I disable the smart array controller (this is used for the internal disk, and I don't want the new process to overwrite the other boot/root device)
3. how do i assign the boot LUN id to the primary boot in the qlogic firmware
4. the acu allows me to create a lun on the MSA1500 but how do I relate it to the new boot device
2 REPLIES
Jimmy Vance
HPE Pro

Re: install/boot sles10 from san

The instructions are in the document you mentioned

1) Using ACU create a LUN, turn on SSP (Selective Storage Presentation) assign the LUN to the WWID of your HBA

2) You don't really need to disable the SA controller, just change the boot order so your fibre HBA is before the SA controller.

To be safe you can unplug the disks from the SA controller, or from within RBSU select PCI devices and disable the SA controller.

3) You don't say what HBA you have, assuming QLogic. When the system is going through post press CTRL-Q when the QLogic HBA shows up on your screen. Enable the QLogic BIOS, Enable the boot option, select the LUN you want to boot from (Short version of step 2D in the guide)

4) refer to 1




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
joseph pareti
Frequent Advisor

Re: install/boot sles10 from san

Thanks, I installed sles10 on the "array c lun 3" (see enclosure), but when attempting to boot from it I get the message "Attempting to boot from the hard drive (c:)" and nothing else happens.

According to "HP StorageWorks booting Linux x86 from a san app notes" (october 2007)", page 8, the only unit that is bootable to a linux host connection is LUN 1. This might be my problem because I am trying to boot from LUN 3, isn't it? How can I change the LUN ordering without destroying the data (LUN 1 and 2 are used for another app)