System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

install tcsh on HP-UX B.11.11 U 9000/800

 
avivi
Occasional Contributor

install tcsh on HP-UX B.11.11 U 9000/800

hello
i have HP-UX maci B.11.11 U 9000/800 3348475325 unlimited-user license
and i want to install tcsh , what release of tcsh i need ?
4 REPLIES
James R. Ferguson
Acclaimed Contributor

Re: install tcsh on HP-UX B.11.11 U 9000/800

Hi:

See:

http://hpux.connect.org.uk/hppd/hpux/Shells/tcsh-6.14.06/

In your case, if you want the binary (pre-compiled), use the one for 11.11 and install its run-time dependencies, too. Otherwise roll (compile) your own from the source, again honoring the necessary build-time dependencies.

Regards!

...JRF...
avivi
Occasional Contributor

Re: install tcsh on HP-UX B.11.11 U 9000/800

thanks
i download the file , and unzip , after that , i do the command swinstall and get error , what to do ?
# swinstall -s /home/maci/avivi/tcsh-6.14.06-hppa-11.11.depot tcsh

======= 03/17/09 23:10:23 GMT BEGIN swinstall SESSION
(non-interactive) (jobid=maci-0039)

* Session started for user "root@maci".

* Beginning Selection
* Target connection succeeded for "maci:/".
NOTE: The software "tcsh" was successfully marked, but it depends on
the following software items which could not be found in the
source. However, these items may already be in the target.
This will be checked during the Analysis Phase:
libiconv.libiconv-RUN termcap.termcap-RUN
* Source:
/home/maci/avivi/tcsh-6.14.06-hppa-11.11.depot
* Targets: maci:/
* Software selections:
tcsh.tcsh-RUN,r=6.14.06,a=HP-UX_B./800
* Selection succeeded.


* Beginning Analysis and Execution
* Session selections have been saved in the file
"/.sw/sessions/swinstall.last".
ERROR: "maci:/": The software dependencies for 1 products or
filesets cannot be resolved.
* The analysis phase failed for "maci:/".
* Analysis and Execution had errors.


NOTE: More information may be found in the agent logfile using the
command "swjob -a log maci-0039 @ maci:/".

======= 03/17/09 23:10:26 GMT END swinstall SESSION (non-interactive)
(jobid=maci-0039)
Patrick Wallek
Honored Contributor

Re: install tcsh on HP-UX B.11.11 U 9000/800

>>NOTE: The software "tcsh" was successfully
>>marked, but it depends on the following
>>software items which could not be found in
>>the source. However, these items may already
>>be in the target.
>>This will be checked during the Analysis
>>Phase:
>>libiconv.libiconv-RUN termcap.termcap-RUN

TCSH depends on the LIBICONV and TERMCAP packages. You either need to make those part of the TCSH bundle or install them first.
James R. Ferguson
Acclaimed Contributor

Re: install tcsh on HP-UX B.11.11 U 9000/800

Hi (again):

> i download the file , and unzip , after that , i do the command swinstall and get error , what to do ?

Did you read what I wrote about _dependencies_ ? If you examine the contents of the URL that points to the software, you will see the dependencies you need to fetch!

Regards!

...JRF...