System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

installing hp monitoring tools on openSuse 10.0

SOLVED
Go to solution
peter demus
Frequent Advisor

installing hp monitoring tools on openSuse 10.0

hello !

there is no ILO card in the server....

there is a LED blinking on the front panel color orange (the symbol with the heartbeat to the left)

i would like to see all events of the hardware: cpu temp, fans , voltage supply, raid events

hardware : HP ML 150 G3

can i install the hp tools ? it's stated on the web page: rhes 4/5 sles 9/10 supported

installed is openSuse 10.0
i would like to run HP acu cli tool

thanks a lot, peter
jepp!
5 REPLIES
~sesh
Esteemed Contributor

Re: installing hp monitoring tools on openSuse 10.0

Hi, openSUSE is not a supported operating system for the ProLiant servers. This kind of an issue has been discussed elsewhere in the forums, but it is about the System Management Homepage.

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1172480

Moreover since this server doesn't ship with a Smart Array controller, ACU will not work. ACU can only see & report Smart Array Controllers. If you've installed the "HP Smart Array E200/128 BBWC Controller" (the only recommended Array Controller), ACU CLI can be used. However, you can also try installing the other management agents (Insight Diagnostics Offline using the method given in the thread mentioned above. As always, I would like to add that since openSUSE is not supported, the success of the workarounds can not be guaranteed! :)
peter demus
Frequent Advisor

Re: installing hp monitoring tools on openSuse 10.0

hello !

thank You!

do you think there are no kernel version dependicies if i install the system health agent modules ?

uname -a SLES10
Linux xera 2.6.16.27-0.9-smp #1 SMP Tue Feb 13 09:35:18 UTC 2007 i686 i686 i386 GNU/Linux

uname -a openSUSE 10.1
Linux xronix 2.6.16.13-4-smp #1 SMP Wed May 3 04:53:23 UTC 2006 i686 i686 i386 GNU/Linux
p



is ACU CLI directly talking to the PCI device of the RAID controller ??

bye, peter
jepp!
~sesh
Esteemed Contributor

Re: installing hp monitoring tools on openSuse 10.0

I have just had a look at the readme (sp37876.txt) notes for HP Insight Diagnostics Offline Edition (just to clear the confusion about issues with kernel & dependencies) at:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=1163831&swItem=MTX-c993c14e1d024904932babab39&prodNameId=3279687&swEnvOID=2065&swLang=8&taskId=135&mode=4&idx=2

Seems like this package works with SLES 8, SLES 9, SLES 10 and other Linux Operating systems. I don't think you will have any kernel dependency issues because, if this can work with 3 totally different (major) kernel versions, it shouldn't have a problem with minor kernel upgrade versions. You could check the readme for the packages that you want & if all support the same operating systems, you can go ahead. Be sure to check for the dependencies for the rpm you download.

The Array Configuration Utility can only communicate to Array controllers. I am not sure if it talks to the PCI bus or the controller itself, but SATA/SAS integrated controllers (software RAID) will not be detected by ACU. :)
peter demus
Frequent Advisor

Re: installing hp monitoring tools on openSuse 10.0

hello !

so this a hint for the HP Insight Diagnostics OFFLINE edition

the OFFline edition would work also with QNX VMS Solaris or OS/2 because you have to boot from CD... ;-)

i'm trying to see problems with the system health of the ml150 ONLINE.



jepp!
~sesh
Esteemed Contributor
Solution

Re: installing hp monitoring tools on openSuse 10.0

That's true. The point is that if the software you are looking for supports different OS versions, then minor kernel version differences would not make any difference. The problem is I can't see a utility that you can use to monitor system health status online, so had to pick that example (a bad one). :)

The only software relevant to system health reporting is: Insight Management Agents (HP ASM).

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=1163831&prodNameId=3279687&swEnvOID=2065&swLang=8&mode=2&taskId=135&swItem=MTX-UNITY-I25082

Try installing this RPM with --noscripts or --nopre switch.

Just deviating from the topic, SLES 10 itself is available for download, and free updates are available with the 60 day free activation. You will get email alerts about updates & patches, so head to the novell site and download them, instead of applying them as "automatic updates".

http://www.novell.com/products/server/eval.html