System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

ioinit: Instance number 0 already exists for class tape.

 

ioinit: Instance number 0 already exists for class tape.

we added new SAN switches in our data center and we made zoning from scratch. after the new zoning the server geting the existing tape library with the new hardware paths.

server: rx7640.     OS: HP-UX 11.31

# ioscan -fnkC tape
Class     I  H/W Path  Driver S/W State   H/W Type     Description
==================================================================
tape      4  0/0/14/1/0.1.10.255.0.0.1  stape   CLAIMED     DEVICE       HP      Ultrium 4-SCSI
                      /dev/rmt/4m             /dev/rmt/4mn            /dev/rmt/c47t0d1BEST    /dev/rmt/c47t0d1BESTn
                      /dev/rmt/4mb            /dev/rmt/4mnb           /dev/rmt/c47t0d1BESTb   /dev/rmt/c47t0d1BESTnb
tape      5  0/0/14/1/0.1.10.255.0.0.2  stape   CLAIMED     DEVICE       HP      Ultrium 4-SCSI
                      /dev/rmt/5m             /dev/rmt/5mn            /dev/rmt/c47t0d2BEST    /dev/rmt/c47t0d2BESTn
                      /dev/rmt/5mb            /dev/rmt/5mnb           /dev/rmt/c47t0d2BESTb   /dev/rmt/c47t0d2BESTnb
#

we want the identifier no should start from 0.

we tried to reset the numbers with this procedure.

# ioscan -fnkC tape | grep -e ^tape -e /dev > /tmp/ioscan.out

# awk 'BEGIN {COUNT=0} $1 ~ /^tape/ {printf "%s\ttape\t%d\n", $3, COUNT++}' /tmp/ioscan.out > /tmp/infile

# cat /tmp/infile
0/0/14/1/0.1.10.255.0.0.1       tape    0
0/0/14/1/0.1.10.255.0.0.2       tape    1
#

# ioinfile -f /tmp/infile

# ioinit -f /tmp/infile
ioinit: Instance number 0 already exists for class tape.
Input line 1:  0/0/14/1/0.1.10.255.0.0.1 tape 0
#

 

also we tried to remove the tape from the server physicaly and delete the device files.

#rmsf -H 0/0/14/1/0.1.10.255.0.0.1

#rmsf -H 0/0/14/1/0.1.10.255.0.0.2

after this we reboot the server and try to install the device files but no luck. it is still keeping identifier no 4 and 5.

anyone can help me the solve this problem.

thanks in advance.

4 REPLIES
Torsten.
Acclaimed Contributor

Re: ioinit: Instance number 0 already exists for class tape.

>>

# ioinit -f /tmp/infile
ioinit: Instance number 0 already exists for class tape.
Input line 1:  0/0/14/1/0.1.10.255.0.0.1 tape 0
#

 

Did you do this AFTER the reboot?

 

See also

http://community.hpe.com/t5/System-Administration/How-to-change-a-card-instance-number-in-HP-unix/m-p/3787731#M264402

/t5/System-Administration/How-to-change-a-card-instance-number-in-HP-unix/m-p/3787731#M264402


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   

Re: ioinit: Instance number 0 already exists for class tape.

Hi Torsten,

i followed the instructions given in the link you have provided. see the output from ioinit prompt.

(in ioinitrc)# /sbin/ioinit -f /infile -r
ioinit: Instance number 0 already exists for class tape.
Input line 38:  0/0/14/1/0.1.10.255.0.0.1 tape 0

it is not applying the changes. just giving the message that is " Input line 38:  0/0/14/1/0.1.10.255.0.0.1 tape 0 ".

 

Torsten.
Acclaimed Contributor

Re: ioinit: Instance number 0 already exists for class tape.

did you move the old database file?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   

Re: ioinit: Instance number 0 already exists for class tape.

hi,

yes i did. i moved /etc/ioconfig and /stand/ioconfig files. then i rebooted the system.

system came up in ioinit prompt and i issued these commands.

ioinitrc# /sbin/ioinit -c

(in ioinitrc)# /sbin/ioinit -f /infile -r
ioinit: Instance number 0 already exists for class tape.
Input line 38:  0/0/14/1/0.1.10.255.0.0.1 tape 0

it is not applying the changes because given message.