cancel
Showing results for 
Search instead for 
Did you mean: 

iscsi mutipathing

DeafFrog
Valued Contributor

iscsi mutipathing

Dear Gurus ,

We have 2 10G card , in each of the 2 M160 dell blades,running Redhat el 5.5 .
all 4 iscis hba's have been assigned IP and granted access to iscsi target which
resides in a equallogic iscsi san ,mutilpath -l does shows only one entry.
how to set the mutipath properly.

Regards,
FrogIsDeaf
2 REPLIES
DeafFrog
Valued Contributor

Re: iscsi mutipathing

Hi,

in case some one stumbles along this thread ..the solution is in red hat knowledge base article :34404 , also the sam e is mentioned in equallogic iscsi configuration guide
=====cut and paste====
Configuring Mulitpath Connections:
To create the multiple logins needed for Linux dev-mapper to work you need to create an â interfaceâ file for each GbE interface you wish to use to connect to the array.
Use the following commands to create the interface files for MPIO.
(Select the appropriate Ethernet interfaces youâ re using.)
#iscsiadm -m iface -I eth0 -o new
New interface eth0 added
Repeat for the other interface, i.e. eth1
#iscsiadm â m iface â I eth1 â o new
New interface eth1 added
Now update the interface name for each port:
#iscsiadm â m iface â I eth0 - -op=update â n iface.net_ifacename â v eth0
eth0 updated
#iscsiadm â m iface â I eth1 - -op=update â n iface.net_ifacename â v eth1
eth1 updated
Hereâ s an example of what the /var/lib/iscsi/ifaces/eth0 looks like:
iface.iscsi_ifacename = eth0
iface.net_ifacename = eth0
iface.hwaddress = default
iface.transport_name = tcp
If you have already discovered your volumes, you now need to re-discover the target(s).
#iscsiadm â m discovery â t st â p :3260
172.23.10.240:3260,1 iqn.2001-05.com.equallogic: 0-8a0906-83bcb3401-16e0002fd0a46f3d-rhel5-test
172.23.10.240:3260,1 iqn.2001-05.com.equallogic: 0-8a0906-83bcb3401-16e0002fd0a46f3d-rhel5-test
You should see an entry for each interface you specified.
You now need to log into the volume.
#iscsiadm â m node â l â T iqn.2001-05.com.equallogic:0-8a0906-8951f2302-815273634274741f-rhel5-test â p 172.23.10.240:3260
#iscsiadm â m session
tcp: [3] 172.23.10.240:3260,1 iqn.2001-05.com.equallogic: 0-8a0906-83bcb3401-16e0002fd0a46f3d-rhel5-test
tcp: [4] 172.23.10.240:3260,1 iqn.2001-05.com.equallogic: 0-8a0906-83bcb3401-16e0002fd0a46f3d-rhel5-test
This shows that both adapters have connected to the array.
Verify that the multipathing is correctly configured.
#multipath â v2
#multipath â ll
dw-test-vol (36090a02830f251891f74744263735281) dm-1 EQLOGIC,100E-00
[size=100G][features=1 queue_if_no_path][hwhandler=0]
\_ round-robin 0 [prio=0][active]
\_ 9:0:0:0 sdd 8:48 [active][ready]
\_ 8:0:0:0 sde 8:64 [active][ready]
dw-svr-vol (36090a01840b31c74e173a4873200a02f) dm-0 EQLOGIC,100E-00
[size=10G][features=0][hwhandler=0]
\_ round-robin 0 [prio=0][enabled]
\_ 6:0:0:0 sdb 8:16 [active][ready]
\_ 7:0:0:0 sdc 8:32 [active][ready]
In this example you see that there are two paths to each volume. They are set one on top of the other. If they are separated, then MPIO is not working correctly. Try restarting the multipath service and check again. If not, review your multipath configuration file for any errors.
#service multipathd restart
Other resources for configuring MPIO can be found at:
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/DM_Multipath/mpio_configfile.html
http://kbase.redhat.com/faq/docs/DOC-3353

closing the thread
Regards,
FrogIsDeaf
DeafFrog
Valued Contributor

Re: iscsi mutipathing

Hi , solution as above.

Reards ,
Rahul.
FrogIsDeaf