System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

kernel parameter cant be changed

MahdiRa
Frequent Advisor

kernel parameter cant be changed

i have ES40 with Tru64 version 4.0f every time am trring to change the parameter "max-proc-per-user" from 64 to 512 but when i went to issue the command "sysconfig -q proc" i sow that the value is 256 and some users still cant connect to the system because of this problem
Mahdi
10 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: kernel parameter cant be changed

Hi,

this parameter can not be changes at run time, must be entered in /etc/sysconfigtab and the machine rebooted. Have you done that?

greetings,

Michael
Johan Brusche
Honored Contributor

Re: kernel parameter cant be changed

Mahdi,

Each process has at least 1 thread, and a lot of application processes have several threads.

I bed that max_threads_per_user was not increased equally with max_proc_per_user.
It is recommended to have max_threads=4*max_proc .

Unfortunately yoou will have to boot again to make it active.

Rgds,
____ Johan./

_JB_
MahdiRa
Frequent Advisor

Re: kernel parameter cant be changed

Dear michael
I rebooted the system but i get nothing changed by the way i also changed the value of the threads.
Mahdi
Michael Schulte zur Sur
Honored Contributor

Re: kernel parameter cant be changed

Can you post the proc section from /etc/sysconfigtab
?

Thanks,

Michael
Johan Brusche
Honored Contributor

Re: kernel parameter cant be changed


And remember there are also the system-wide maximum parameters "taskmax" and "threadmax".
Those can only be increased indirectly by increasing proc:maxusers, but that one can be modified online with : sysconfig -r proc maxusers=[nnnn].

Rgds,
____ Johan ./

_JB_
Hein van den Heuvel
Honored Contributor

Re: kernel parameter cant be changed


Can we get an exact error message?
Fresh message in /var/adm/messages
You are not getting: " pid table is full " are you?

Can other users, using a different username, log in while one username gets a problem?
(Is it not better to have more, unique, usernames anyway?)

I concur with the request of a view of the sysconfigtab file. Can you attach the bottom part as a .txt here?
Maybe there is a duplicate entry?
Maybe there is a bad spelling?
Your topic uses dashes in the word.
Tried underscores? max_proc_per_user

Have you googled around for earlier discussion on similar questions? +tru64 + 'max_proc_per_user'
Maybe add +site:itrc.hp.com?
For example:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?t

fwiw,
Hein.
Michael Schulte zur Sur
Honored Contributor

Re: kernel parameter cant be changed

Also watch the console during reboot for errors concerning unknown parameters.

Michael
Joris Denayer
Respected Contributor

Re: kernel parameter cant be changed

Hi,

Between V4 and V5, there was a change in the sysconfigtab dash/underscore usage.

In V4.* , a dash is used in the names
In V5.* , an underscore is used, but a dash is also recognised

so
max-proc-per-user in V4
and
max_proc_per_user or max-proc-per-user in V5

So, be sure that only dashes are used (-)

Joris
To err is human, but to really faul things up requires a computer
Joris Denayer
Respected Contributor

Re: kernel parameter cant be changed

Mahdi,

You say that users can't connect to the system. Do you have enough ptys configured. If not, you won't get higher then ~32 telnet sessions.
If this is the problem, you should create extra pty devices with the MAKEDEV command. (see the manpage)

Joris
To err is human, but to really faul things up requires a computer
Michael Schulte zur Sur
Honored Contributor

Re: kernel parameter cant be changed

Hi,

what error message does the user get when he tries to login?

Michael