Showing results for 
Search instead for 
Did you mean: 

kickstart install failes

Go to solution
Frequent Advisor

kickstart install failes


I'm trying to install a new machine threw a kickstart but it hangs at "determining host name and domain".
If I go Alt+F3 I see that it :
getting kickstart file
sending dhcp request through device eth0
waiting for link...
5 seconds.
running dhcp for eth0
doing kickstart... setting it up
waiting for link...
0 seconds.
reverse name lookup failed.
ks location: http://inst-lnx/linux-instal/anakonda-ks.cfg
transferring http://inst-lnx/linux-instal/anakonda-ks.cfg to a fd
failed to retrieve http://inst-lnx/linux-instal/anakonda-ks.cfg

2 questions :
I use a static IP in my anakonda file :
network --device eth0 --bootproto static --ip --netmask --gateway --nameserver, --hostname lnxl1.server

1. Why does it requested a dhcp after reading the kickstart file ?
2. Where am I wrong ?
Joseph L. Casale
Regular Advisor

Re: kickstart install failes

Although you may instruct kickstart to configure the system with a static ip, it needs an ip address to initially develop network connectivity so it can even fetch the ks file from your http server, that's why it sends a DHCP request out.

You seem to have issues finding your http server by the non qualified domain name. Check what configuration you have been handed out by your dhcp server and resolve your dns problem, does it work if you specify the ip of the http server?

Check out section 30.10 from the RHEL 5.3 Installation Guide: for specifying a static ip and other options at the command line when starting the install.

Frequent Advisor

Re: kickstart install failes

all the names in the anaconda-ks.cfg where replaced by IP's.
Also the kickstart server name in pxelinux.cfg/default was replaced by an IP - still nothing.

I've noticed that in other segments the installation works fine (stupid security team), but I don't know what to look for, any particular port ?
Steven E. Protter
Exalted Contributor

Re: kickstart install failes


Network administrators generally set up server rack areas so that dhcp is not possible. They generally don't make the set up vary port by port, but they can.

For some reason the network port you are using is configured for dhcp.

I would replace inst-lnx in the string with an IP address and see if this improves the install. There could be a DNS server inconsistency that is causing the lookup to fail.

Reverse lookup check sees it the IP address has a reverse lookup that associates the IP address with the local domain. This is commonly not done by DNS admins.

Steven E Protter
Owner of ISN Corporation
Frequent Advisor

Re: kickstart install failes

The problem was in assigning the dhcp leasse.

I configured the wrong DNS server in /etc/dhcpd.conf and it caused all my problems.

Thank you for your help.