cancel
Showing results for 
Search instead for 
Did you mean: 

launch xterm from ksh

 
SOLVED
Go to solution
user001
Frequent Advisor

launch xterm from ksh

Hi,

 

Having a bit of problem with my korn shell.

 

I'm running 11.31

 

when i ssh in and type xterm & at the shell it launches the xterm windows as expected.

 

but lets say i want another one e.g. two concurrent xterm windows....

 

open devtty: permission denied

 

this message repeats until i close the first window.

 

this doesn't happen on another user account running tcsh.

 

any ideas, its a bit of weird problem and i'm beginning to think it may be a bug.

 

cheers.

3 REPLIES
Steven Schweda
Honored Contributor

Re: launch xterm from ksh

   As usual some actual information might be helpful, for example:

> I'm running 11.31

   On what?

      uname -a

      echo $DISPLAY

> this doesn't happen on another user account running tcsh.

   That sounds like a clue.  What's different between the two users?
Shell start-up files  ("~/.profile", or whatever your shell uses)?  Move
yours to some other name/place, and see if that makes a difference?

> [...] i'm beginning to think it may be a bug.

   It's very likely a bug somewhere, possibly in your stuff.

user001
Frequent Advisor
Solution

Re: launch xterm from ksh


not quite sure i understand your what question....

its an rx2600

display = XXX.XXX.XXX.XXX:10.0

Its not a problem running a gui though, the first attempt works its running multiple xterm windows which is the problem.

the startup files are very different.

i'll create a dummy user now using a korn shell and the working profile and update later today...

...well played
user001
Frequent Advisor

Re: launch xterm from ksh

fixed it.

permissions problem, looks like some of the files had another group membership on it which may have been causing the problem because now it works.

thanks for pointing me towards to profile files.