System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: ld: Can't find library for -lz

 
anup1890
Occasional Advisor

ld: Can't find library for -lz

Hi,
We are facing below linking error for our 64bit compilation. We are not able to find 64bit library for the same. The link given in one of the thread is also not working. (http://hpux.connect.org.uk/hppd/hpux/Misc/zlib-1.2.3/). We are also not sure whether libz and zlib are one and the same. Could you please help..........

Thanks
5 REPLIES 5
Jose Mosquera
Honored Contributor

Re: ld: Can't find library for -lz

Hi,

You have available a new version:
http://hpux.connect.org.uk/hppd/hpux/Misc/zlib-1.2.5/

Rgds.
Jose Mosquera
Honored Contributor

Re: ld: Can't find library for -lz

Hi again,

At zlib Home Site you can find full detailed info about current version improvements and cross plataform versions.
http://zlib.net/

In any case, if 1.2.5 is good for you I suggest you my previous post, there you find a depot format ready to install in HP-UX.

Rgds.
anup1890
Occasional Advisor

Re: ld: Can't find library for -lz

Hi Jose,

Thanks for the quick response.

We are looking for a 64 bit depot version of the zlib (now that we know zlib & libz are the same :) ). The depot build available in the link given by you is only for 32 bit.

Would it be possible for you to let us know if any such build is available as we couldn't find anything anywhere...

Thanks again...

Cheers,
-Anup
Jose Mosquera
Honored Contributor

Re: ld: Can't find library for -lz

Hi Anup,

From http://zlib.net/zlib_faq.html:

(FAQ#26) Will zlib work on a 64-bit machine?
Yes. It has been tested on 64-bit machines, and has no dependence on any data types being limited to 32-bits in length. If you have any difficulties, please provide a complete problem report to zlib email address(*).

(*) The email address is provided into original FAQ#26.

The answer suggest a package which is a 32-bit source code compatible with 64-bit, of course fails to capitalize on the strength of a native code in 64-bit. In any case you could contact them for reliable info about this.

Rgds.
anup1890
Occasional Advisor

Re: ld: Can't find library for -lz

I had in the mean time built the sorce code available for 64-bit support..

Thanks for the support...

It was very helpful and I have assigned points for the same.

Hope it helps...