HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

liprpmio-4.4.so error using Oracle EL 5 (64) in Proliant ML 150

 
Andrés Caro
Occasional Contributor

liprpmio-4.4.so error using Oracle EL 5 (64) in Proliant ML 150

Hi everybody, We have some problems installing Oracle Enterpise Linux 5 (64 bits) in our Proliant ML 150 Server. After installing Linux in boot sequence we get ImportError: librpmio-4.4.so: cannot open shared object file: No such file or directory.

When we try to open pirut (Add or remove programs) or rpm, we get the same code "error loading shared libraries: librpmio-4.4.so: cannot open shared object file: No such file or directory".

After a short search i found the file in /usr/lib, then i did an export LD_LIBRARY_PATH=/usr/lib, now i get: "error while loading shared libraries: librpmio-4.4.so: wrong ELF class: ELF CLASS32".

We don´t get any errors installing the 32 bit version of OEL 5. Any idea?
3 REPLIES
Ivan Ferreira
Honored Contributor

Re: liprpmio-4.4.so error using Oracle EL 5 (64) in Proliant ML 150

During installation, ¿have you selected the compatibility libraries?

¿Did you change the LD_ASSUME_KERNEL variable?

Please post the output of:

getconf LONG_BIT
rpm -qa --queryformat %-{name}-%{version}-%{release}-%{arch}"\n" | grep glibc
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Andrés Caro
Occasional Contributor

Re: liprpmio-4.4.so error using Oracle EL 5 (64) in Proliant ML 150

getconf LONG_BIT shows "64"

The rpm query don´t work, as I said before when i try to run rpm i get the librmpio-4.4.so error.

We didn´t make any changes or updates after installing OEL 5 (64 bits). These is a clean installation.
Andrés Caro
Occasional Contributor

Re: liprpmio-4.4.so error using Oracle EL 5 (64) in Proliant ML 150

I downloaded the last version available (OEL 5 Update 3 for 64 bits), after install this Oracle Enterprise Linux 5 updated version, I didn´t get any errors with rpm or related librpmio-4.4.so erros.

Until now Proliant ML150 is running very well with OEL 5 and Oracle Data Base in 64 bit.

Thanks to all users that replied to this tread.