cancel
Showing results for 
Search instead for 
Did you mean: 

mount nfs i/o error

SOLVED
Go to solution
Nicolaï
Occasional Advisor

mount nfs i/o error

hello,

i'm trying to mount a remote directory (W2k with nfs server running )
on unix the command mount fail =>

#mount -F nfs srv-nas1:/unix-bases /nas1
=>nfs mount: mount_nfs: mount: /nas1: I/O error

(the nfs daemon are running and the directory on w2k is nfs shared for anonymous login...)

thanks for help !
15 REPLIES
Geoff Wild
Honored Contributor

Re: mount nfs i/o error

How about trying to do it the other way around - see if the W2K server can nfs mount a nfs share from your HP-UX box.

mkdir /tmp/w2k

add to /etc/exports:

/tmp/w2x -rw=srv-nas1

exportfs -a

Also, is your nfs client running?

Check /etc/rc.config.d/nfsconf and make sure NFS_CLIENT and NFS_SERVER are set to 1

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Nicolaï
Occasional Advisor

Re: mount nfs i/o error


ok, the nfs client of w2k success to
map a drive on the nfs directorie
of unix (/tmp/w2k).

if you've an idea why my "mount" fail ...

( In my /etc/rc.config.d/nfsconf ,NFS_CLIENT and NFS_SERVER are set to 1 )




Stanimir
Trusted Contributor

Re: mount nfs i/o error

Do you run an NFS-server on Win2k?
Which is your NFS-server?
Check NFS-server configuration.
Regards.
Donny Jekels
Respected Contributor

Re: mount nfs i/o error

which nfs server are you running, it must work.
"Vision, is the art of seeing the invisible"
Stanimir
Trusted Contributor

Re: mount nfs i/o error

You have to share /unix-bases - directory
from "srv-nas1" to your unix-server
by NFS-server-configuration.
Regards.
Stanimir
Trusted Contributor

Re: mount nfs i/o error

You have to share /unix-bases - directory
from "srv-nas1" to your unix-server
by NFS-server-configuration.
Regards.
Nicolaï
Occasional Advisor

Re: mount nfs i/o error

my nfs server on windows 2000 is :
Microsoft Windows Services for UNIX 2.2.

this service is running and my directory
/unix-bases is shared and accept anonymous
access (uid=-2 and gid=-2) ..

Massimo Bianchi
Honored Contributor

Re: mount nfs i/o error

Maybe that for some reasons the biod are dead.


Try stopping/restarting them on the hpux server


/sbin/init.d/nfs.client stop;
/sbin/init.d/nfs.client start;


Also check if they are re-started in /var/adm/syslog/syslog.log

Massimo

Nicolaï
Occasional Advisor

Re: mount nfs i/o error

it is restarted but no change ...

#mount -e -F nfs srv-nas1:/unix-bases /nas1
=>nfs mount: mount_nfs: mount: /nas1: I/O error

Nicolaï
Occasional Advisor

Re: mount nfs i/o error

can someone give me a link to
mount command documentation please ?

thanks.
Massimo Bianchi
Honored Contributor

Re: mount nfs i/o error

Geoff Wild
Honored Contributor
Solution

Re: mount nfs i/o error

man 1m mount

Do you have any other boxes that you can test the nfs mount?

I wonder if you need a -o version=3 or something like that....

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Nicolaï
Occasional Advisor

Re: mount nfs i/o error


i've tested all the possible option of
the mount command (vers=2/3,nosuid,soft ....)
but the error is always the same
=>nfs mount: mount_nfs: mount: /nas1: I/O error

i've tested in a unix SCO too and it makes
the same error (i/o error ) !!

In the log of the w2k nfs server, i see that
the mount are success all the time i do a mount on unix ...

thanks for your help !
Nicolaï
Occasional Advisor

Re: mount nfs i/o error

Sucess !!!

I've download the version 'window service for
unix 3.0' and it works ...

geoff you'was right,it was a question of version !! Send me a new message and i'll
give you points.

thanks all for the help
Nicolaï
Occasional Advisor

Re: mount nfs i/o error

it's ok geoff, i've gave you point on
your previous message ...