System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

move hdd to different machne, and linx doesnt boot properly

SOLVED
Go to solution
Maaz
Valued Contributor

move hdd to different machne, and linx doesnt boot properly

installed suse 10, on machine A(machine A mainboard burned), then move the hdd, to machine B(on the same controller .. /dev/hda, and machine B has a different system/main board) ... but getting error. Following are the messages I received on console, of machine B, during startup/boot
.
.
.
Loading fan
Loading edd
BIOS EDD facility v0.16 2004-June-25, 1 device found
Load reiserfs
resume device /dev/hda3 not found (ignoring)
Waiting for device /dev/hda2 to appear: ^[...... not found -- exiting to /bin/sh
$

I boot the system in rescue, then ran mount command
# mount
/dev/hda2 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/hda1 on /boot type reiserfs (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
/dev/hdd on /media/New type iso9660 (ro,nosuid,nodev,utf8,uid=0)
/dev/sda1 on /mnt type vfat (rw)

# fdisk -l
Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 13 104391 83 Linux
/dev/hda2 14 1972 15735667+ 83 Linux
/dev/hda3 1973 2038 530145 82 Linux swap / Solaris
/dev/hda4 2039 4865 22707877+ f W95 Ext'd (LBA)

Even I ran fsck, successfuly..and fsck doesnt show any error
# fsck -y /dev/hda2
then
# fsck -y /dev/hda2

# mount /dev/hda2 /mnt
# mount --bind /dev /mnt/dev
# chroot /mnt
then
# cat /etc/fstab
/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hda1 /boot reiserfs acl,user_xattr 1 2
/dev/hda3 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

plz help me, what should I do
2 REPLIES
Ivan Ferreira
Honored Contributor
Solution

Re: move hdd to different machne, and linx doesnt boot properly

Identify the modules loaded with the rescue cd. maybe a required module for the storage controller is not included in the initial ram disk. If you identify the module needed for the storage device, rebuild the initial ramdisk with mkinitrd in the chrooted rescue file system.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Maaz
Valued Contributor

Re: move hdd to different machne, and linx doesnt boot properly

NICE/SUPERB HELP/SUPPORT ;)
Millions of Thanks Dear Mr Ivan Ferriera, for such a nice help.
what i did is, simply as per your instruction, boot the system in rescue mode,
# mount /dev/hda2 /mnt
# mount /dev/hda1 /mnt/boot
# mount --bind /dev /mnt/dev
# chroot /mnt
then
# mkinitrd
in redhat, i m sure, we type
mkinitrd /boot/initrd-`uname -r`.img `uname -r`
but in suse we only type "mkinitrd"

DONE ;)
Regards
Maaz