System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

multipathing with sles10 and eva4400

iinfi1
Super Advisor

multipathing with sles10 and eva4400

We have sles 10 (suse 10) servers with eva4400 storage.
Does the procedure for multipathing change from OS to OS and Storage to Storage?
this system was given to me to manage from another team and i have no clue how they have done the multipathing. I have never done it before.
i tried to simulate it using iscsi on a vmware workstation but didnt get any success.
Any help as to how i should proceed appreciated
6 REPLIES
Kapil Jha
Honored Contributor

Re: multipathing with sles10 and eva4400

It depends what software you are using?

if using multipath it would be not be very trouble some.
may be this can help
http://support.novell.com/techcenter/sdb/en/2005/04/sles_multipathing.html

BR,
Kapil+

I am in this small bowl, I wane see the real world......
Viktor Balogh
Honored Contributor

Re: multipathing with sles10 and eva4400

Do you have the VxVM (Veritas Volume Manager) installed? If yes, the multipathing probably be done by the Veritas DMP (Dynamic Multipathing).

http://eval.symantec.com/mktginfo/enterprise/white_papers/ent-whitepaper_vsf_5.0_dynamic_multi-pathing_05-2007.en-us.pdf
****
Unix operates with beer.
Jimmy Vance
HPE Pro

Re: multipathing with sles10 and eva4400

HP recommends using the inbox Device Mapper multipathing (DM Multipath)

To see if DM multipath is running, use these commands:

# chkconfig boot.device-mapper
# chkconfig list boot.multipath
# chkconfig list multipathd

The above commands will return "on" if DM multipath is in use.

# multipath -l will show you the configured paths


For more information go to http://www.hp.com/go/devicemapper and download the latest HPDMMultipath kit for your distribution and review the included documentation.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
iinfi1
Super Advisor

Re: multipathing with sles10 and eva4400

thanks for your replies.

this is what i get if i run the above commands.

haad-oas4:~ # chkconfig --list | grep boot.device
haad-oas4:~ # chkconfig --list | grep device-mapper
haad-oas4:~ # chkconfig --list | grep boot.multipath
haad-oas4:~ # chkconfig --list | grep multipathd
multipathd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
haad-oas4:~ # man multipath
Reformatting multipath(8), please wait...
haad-oas4:~ # multipath -l
DM multipath kernel driver not loaded

does that mean that the the OS multipath is not used?
Jimmy Vance
HPE Pro

Re: multipathing with sles10 and eva4400

that shows device mapper is not being used



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
iinfi1
Super Advisor

Re: multipathing with sles10 and eva4400

hi,

thanks
Is there any way i can find out how its being done?