cancel
Showing results for 
Search instead for 
Did you mean: 

need help for vrestore

madan_2
Advisor

need help for vrestore

Hi Friends

I have Tru64 4.0 f HP Alpha server 4100
I have taken backup of / /usr /usr/user using following commands,

/sbin/mt -f /dev/nrmt0h rew

vdump -0 -u -f /dev/nrmt0h /
vdump -0 -u -f /dev/nrmt0h /usr
vdump -0 -u -f /dev/nrmt0h /usr/user

Now I want to restore this backup because my server has problem and it's not starting how can I restore this backup using vrestore in single user mode or in multiuser mode,

please guide me
8 REPLIES
Ivan Ferreira
Honored Contributor

Re: need help for vrestore

>>> and it's not starting

¿What is the command that you executed and the error that you get?

¿What is the ouput of?:

mt -f /dev/nrmt0h status
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
madan_2
Advisor

Re: need help for vrestore

Hi Ivan Ferreira

Thanks for ur prompt reply

actually my Tru64 4.0F having some disk problem, now hp has replaced disk and I want restore my /, /usr, /usr/users

I don't know how to restore this backup as I have valid backup of this mount point.
Rob Leadbeater
Honored Contributor

Re: need help for vrestore

Hi,

Can you boot the system at all at the moment ?

You will probably need to boot up of the OS CD, and restore from there...

Let us know if you need further help.

Cheers,

Rob
madan_2
Advisor

Re: need help for vrestore

Hi

yes I am able to boot to server in single user mode.
Rob Leadbeater
Honored Contributor

Re: need help for vrestore

OK. If you can get to single user, that implies that your root file system is working to a degree.

Before you launch into restoring, can you explain exactly what happens when you try to boot normally, and what hardware has been replaced etc.

Cheers,

Rob
madan_2
Advisor

Re: need help for vrestore

Hi

We have 2 node TruCluster, yesterday evening our both the server restarted and giving

DUMP: dump to (showing some hexadecimal nos.)

then server started in SRM prompt and I have started the server using boot command, all processs started normally but when it comes to ase services and mounting some filessystems and it's unable to mount some filesystems it again rebooted and showing DUMP: dump to same messages

So we have started server in single user mode then run bscheckrc command started it init3 but when when we starts ase manually giving error like

to start asedirector run level S is required.






George Denyer_1
Frequent Advisor

Re: need help for vrestore

Are you sure it's the OS disk that HP replaced? Because if it was you wouldnt be able to boot to single user, and if it wasnt you wouldnt need to restore you / or /usr filesystems.

Anyway, if your / and /usr filesystems were on the same disk and that disk had to be replaced, the procedure to restore your backups would be:
1) Boot from the OS CD and exit to the shell
2) Create a new label on your new disk including a suitable boot block with the -t option
3) Edit the disk label so the partiton sizes will be appropiate for you filesystems
4) Create domains and filesets for your filesystems. Use the original names.
5) Mount your new filesystems to temporary directories
6) Restore your backups to the newly created filesystems
7) Shutdown and boot normaly
Rob Leadbeater
Honored Contributor

Re: need help for vrestore

Hi,

It doesn't sound like you need to restore root, usr etc.

Rather than make us guess, can you please post the exact error messages that you're getting when trying to "mount some filesystems", and a detailed description of the hardware setup.

Cheers,

Rob