HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

need to change kernal value in hpux 11.11

 
SOLVED
Go to solution
Sreer
Valued Contributor

need to change kernal value in hpux 11.11

Hi Gurus,
I need to modify the kernal value of maxswapchunks in my system.


root@prod36:.../root # uname -a
HP-UX sdcvr36 B.11.11 U 9000/785 3393557197 unlimited-user license
root@prod36:.../root #

Iam not sure about the kernal value changing in 11.11
Do I need to backup the /stand/system directories?
OR can I change the values via SAM?

if its done through command line pls tell me the steps for the same.

current=2513 target value=6144

many thanks.

Rgds
Sree
7 REPLIES
sarfaraj ahmad
Trusted Contributor

Re: need to change kernal value in hpux 11.11

hi Sreer,

better you do this through SAM, which is also recommended and safe.
system will take care about other things. You just select the value according to your requirement in sam.

you can check man page of kmtune for detail of command mode.

Re: need to change kernal value in hpux 11.11

For 11.11 there is also kmtune(1m) if you don't want to use sam.
muruganantham raju
Valued Contributor

Re: need to change kernal value in hpux 11.11

Hi Sree,
Use the following syntax to change through command line.
kmtune paremeter_name=value
Manix
Honored Contributor

Re: need to change kernal value in hpux 11.11

yes kmtune was replaced by kctune from 11.23 onwards so kmtune= should do !!
HP-UX been always lovable - Mani Kalra
Viktor Balogh
Honored Contributor

Re: need to change kernal value in hpux 11.11

Hi Sreer,

It is a static parameter so you need to restart the system after poking with this. I looked after on a 11.11 system in/etc/conf/master.d/core-hpux, there is no formula for this specific parameter so you can go ahead and change it via command line. --> kmtune

The only thing relating to maxswapchunks is:

*range maxswapchunks<=16384
*range maxswapchunks>=1

and that the default is 256Mbyte.

Regards,
Viktor
****
Unix operates with beer.
Solution

Re: need to change kernal value in hpux 11.11

>Muruganantham: kmtune paremeter_name=value

Actually you need: kmtune -s parameter_name=value
Sreer
Valued Contributor

Re: need to change kernal value in hpux 11.11

Hi Gurus,
Thanks all for your support.
I have changed value via sam. [ reboot was needed.]

Now it successfully changed to new value.

Thanx again and happy new year :-)
rgds
Sree