System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

network printing software on 11.31

SOLVED
Go to solution
donna hofmeister
Trusted Contributor

network printing software on 11.31

I'm working on a brand new 11.31 system that needs to do network printing.

I have 'printcfg' install:

swlist|grep -i printers
PrintCfg B.11.31.07 HP-UX Printers and Plotters Configuration Tool Bundle

When I run 'lpweb' and go to 'add printer' I get:

Printer Management->Add printer

Spooler : RUNNING System Default : NOT DEFINED
------------------------------------------------------------------------------------------------------------------------------------
Add RS-232 printer/plotter

When i run 'smh' and select 'p' (not 'l' (ell))...and drill down to where I am lead to believe that I can install a network printer:

Add Network-Based Printer/Plotter -> │ Add Printer/Plotter Connected to HP JetDirect...

This error pops up:

The HP JetDirect printer software is not installed on your system
(neither the command "/opt/hpnpl/admin/hppi", nor the command
"/opt/hpnp/admin/jetadmin", exists). Therefore, it is not possible
to add a printer that is connected to an HP JetDirect interface.

Checking the software depot, there's nothing (obvious?) for another/additional software package (like the old JetDirect one).

Help?

5 REPLIES
Patrick Wallek
Honored Contributor
Solution

Re: network printing software on 11.31

Hi Donna,

 

HP / HPE (pick whomever you want to blame!) has made it **bleep** near impossible to find a verion of the JetDirect / HPPI / HPNPL software. 

 

The closest I've found is a version from 2002 (?!) here: 

https://support.hp.com/us-en/drivers/selfservice/hp-jd-printer-installer-for-hp-ux-11.x/27349

Note that you have to select UNIX and then HP-UX from the dropdowns in the middle of the page to get the software download to come up.

 

I know we've found newer versions than that, but I have not been able to find anything else on the HP / HPE sites so far.

 

Patrick Wallek
Honored Contributor

Re: network printing software on 11.31

WOW!  HPE **bleep**ed me.   I most certainly did not type the **bleep** in my reply above.  That's hilarious!

donna hofmeister
Trusted Contributor

Re: network printing software on 11.31

well **bleep** (and i did type that!) :-) (but the sentiment remains!)

but seriously -- how do you ship a modern OS with no network printing capability??

so what patrick most gallantly found is --  HP JetDirect Printer Installer for UNIX (E.10.34). it indeed seems that this is the 16-year-old (!!) package that you need to install.

i'll go onto add that smh/sam/lpweb are NOT the packages you want to use to add/modify/delete printers -- even though they claim to be able to.

(i haven't heard back from the user for confirmation, however) it seems that adding the printer's ip address to /etc/hosts, followed by addqueue (i suspect lpadmin might work too) does the trick.

thanks, patrick!

Patrick Wallek
Honored Contributor

Re: network printing software on 11.31

I think that should work as I think that's what I've used for system builds (both internal and customer).

 

It is sad that it's so hard to find a 16 year old piece of software to do something that should be natively included.

Bill Hassell
Honored Contributor

Re: network printing software on 11.31

JetDirect has a sad history of interdivisional bickering. It was created in the HP printer division in Boise. All development was stopped 16 years ago, mostly because there are no significant users of HP printers on HP-UX (Boise's words). After all, the world runs on PCs and Macs. And with the recent splits, there's very little hope for any changes.

The good news is that the one-liners: addqueue, modifyqueue, removequeue, hpnpf and hpnpadmin do all the work with no involvement needed from SMH or SAM. And no, lpadmin can't add a port 9100 printer. You need addqueue to do it right. Be sure to use the options: -r off -b off -t off -i 266

Note also that in the last 20 years, no low cost printers can be used with HP-UX as they require massive raster graphics conversion code specific to each new model. Only midsize to large laser printers can actually print ASCII.



Bill Hassell, sysadmin