System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

networker service not starting

 
SOLVED
Go to solution
Ramaprasad K
Regular Advisor

networker service not starting

Hi experts,

I have a strange issue with my server (rp7420 with HP-UX 11.11). The server is crashing continuously and generating crash files.

No hardware issues as I checked from event/activity logs from MP menu. Only 1 partition with the lone cell board in it. It was working fine till recently when we changed some static kernel parameter and rebooted. Since then its rebooting and crashing.

I am able to go into Single User Mode and 'init 1' runs fine. But when I do 'init 2' while starting network related service, server crashes. Isolated by running the scripts individually from rc2.d, and found out that ' networker' service hangs (only have to hard boot).

When I run 'swverify \*' so many errors are thrown (refer attached file 'swverify.txt') including many files under /opt/networker to be missing. They seem to be only man files, so shouldn't be an issue. But apart from that there seems to be other errors.

Could anyone suggest on how to overcome/isolate the issue and bring up the server.

Points will be given deliberately.

Regards,
Ram.
10 REPLIES
Suraj K Sankari
Honored Contributor

Re: networker service not starting

Hi,
I can see this warnings

>>WARNING: fcT1 is configured into "/stand/vmunix",
but a FCMS interface card has not been detected.

your network card is not detected by the kernel if possible switch off your server and change the pci slot of the card then start your server again .

Suraj
Ramaprasad K
Regular Advisor

Re: networker service not starting

Hi Suraj,

Thanks for your reply.

I am not worried about warnings as there are more errors than warnings. Warnings can be ignored but Errors are to be corrected for the issue to be resolved.

In fact there is no FC HBA installed in the server !!! I suppose, the warning says that there is no FC card but patches have been installed related to them.

Now coming to my issue, I am able to see tape when I so 'ioscan -fnC tape'. I tried taking backup and its going absolutely fine. So is there any way I can copy the missing files under /opt/networker from other server. But I don't find networker folder on another of my 11.11 server. What installation would create networker folder? Is it absolutely necessary for server to come up?

Pl help

Ram.
Bart Paulusse
Respected Contributor

Re: networker service not starting

Hi,

you have a lot of files missing, wrong user and group id set for critical files and lots of errors on kernel patches.
What happened?
The wrong permissions may be corrected by swverify -F but the missing files and patch errors will probably not go away.
Do you have an ignite recovery archive and a backup?

Regards,
Bart
smatador
Honored Contributor
Solution

Re: networker service not starting

Hi,
I suggest you first to correct the corrupt fileset specially those associate with network : PHNE_26305 , PHNE_36125 etc. get them on itrc and reapply.
Many fileset relatif to network had file errors, corrupt.
When you correct network, i suggest you if you don't use networker to swremove it.
Ramaprasad K
Regular Advisor

Re: networker service not starting

Excellent.

Thanks Bart and Smatador.

I shall check your suggestions and get back in case of any issues.

Ram.
Ramaprasad K
Regular Advisor

Re: networker service not starting

One more thing, what is the 'networker' for?
Is it vital for server to come up?

If I swremove it, will other applications and OS work fine?

Also, missing files seem to be only man pages, does that cause 'networker' not to start?

Will swverify -F correct permissions and ownerships on commands under /sbin , /usr/lib and so on...?

Lastly, how could files under /opt/networker go missing and also changes in permissions or ownerships happen? What could be possible reasons? Is there any way to check if someone did it manually? FYI, the system is 'Trusted'.

Many thanks,
Ram.
Pete Randall
Outstanding Contributor

Re: networker service not starting

The "networker" package is backup software from Legato - not necessary for startup. You can safely ignore those errors for now.


Pete

Pete
Ashish Parashar
Frequent Advisor

Re: networker service not starting

Hello Ramaprasad ...

Have you already tried to boot it with your previous kernel ???

networker is the software for backup of the server,hence its not neccessary untill server is up and running :) ....you can install it later as well.

Regards

Ashish
Ramaprasad K
Regular Advisor

Re: networker service not starting

Hi all,

Thanks for your valuable replies.

swverify \* didn't resolve the ownerships and permissions. Tried reinstalling patches which had errors and which were corrupted. Patches with errors installed fine but those corrupted got corrupted again giving the permissions and ownerships of the /sbin commands to be issue.

Finally decided to reinstall OS.

Thanks again for your valuable suggestions.

Regards,
Ram.
Ramaprasad K
Regular Advisor

Re: networker service not starting

Reinstalled OS as issue didn't resolve for aforementioned reasons.

Regards,
Ram.