System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

nfs mount - permission denied!

 
SOLVED
Go to solution
Ron Irving
Trusted Contributor

nfs mount - permission denied!

Hi experts!!

I have an rp7410, with a 500GB lv that I have exported to 2 rp8420's. All servers are running 11.23. The first 8420 sees the mount point no problem, but the 2nd one gives the permission denied error. /etc/fstab is identical on both 8420's.

Any ideas?
Should have been an astronaut.
23 REPLIES
Tingli
Esteemed Contributor

Re: nfs mount - permission denied!

Have you set up the export permission for the 2nd rp8420?
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

On the directory?

dr8420 root /.root # ll -d /backup
drwxrwxrwx 2 root root 96 May 20 09:45 /backup/

How's that?
Should have been an astronaut.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

It's the same as the other 8420...exactly.

Sometimes UNIX makes me cry.
Should have been an astronaut.
Tingli
Esteemed Contributor

Re: nfs mount - permission denied!

I mean the file /etc/exports in rp7410. Are both rp8420 in the line of access?

And need to run /usr/sbin/exportfs -a after the file modification.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

Yup. Already did that too.
Should have been an astronaut.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

A little more info. The 1st 8420 is our production box. The 2nd is our DR box, different subnets. Prod is 10.1.1.16, and DR is 10.216.72.16. Is this a possible reason? I can nslookup using both hostname, and ip addresses.
Should have been an astronaut.
Tingli
Esteemed Contributor

Re: nfs mount - permission denied!

Firewall. Maybe the port (111 and etc.?) between the rp7410 and the 2nd rp8420 need to open.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

I am having the network dude check out ports 1110, and 2049, just for kicks...at 1st glance he said that all network traffic is being allowed from the DR site to here. Sigh.
Should have been an astronaut.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

Ok...here's what I did:

On the dr side, I created a dir called /ron.

I exported it to the 7410, and touched a bunch of files both ways. It works.

Soooooooooooooo:

dr -> rp7410 =nfs-happy
rp7410 -> dr =not so much

I am clearly missing something, besides the brain cells that have mysteriously gone absent.

Any ideas, oh wise gurus??
Should have been an astronaut.
Tingli
Esteemed Contributor

Re: nfs mount - permission denied!

Open the ports both ways.
Anoop P_2
Regular Advisor

Re: nfs mount - permission denied!

If the second 8420 has more than one LAN cards with IPs configured, put in all those IPs in the /etc/exports file against that export mount point and re export it.

I've seen earlier that some times nfs requests go out from a different lan than you think it would and errs out.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

I will try that...what would the syntax be?? There is actually 1 more ip address on the dr-rp8420, at 10.216.72.100.
Should have been an astronaut.
SUDHAKAR_18
Trusted Contributor
Solution

Re: nfs mount - permission denied!

On NFS server, export the file system using
#exportfs -i -o root= /
then try to mount from client system.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

THE FABULOUS PRIZE HAS BEEN AWARDED!!

Now...how do I make it so it mounts every time? What's the syntax for the /etc/exports?

Thank you again.
Should have been an astronaut.
Sunny123_1
Esteemed Contributor

Re: nfs mount - permission denied!

following is example of export syntax

usr/games cocoa fudge # export to only these machines
/usr -access=clients # export to my clients
/usr/local # export to the world
/usr2 -access=bison:deer:pup # export to only these machines
/var/adm -root=bison:deer # give root access only to these
/usr/new -anon=0 # give all machines root access
/usr/temp -rw=ram:alligator # export read-write only to these
/usr/bin -ro # export read-only to everyone
/usr/stuff -access=bear,anon=-2,ro # several options on one line
/usr/subnet -access=@mysubnet #use mysubent in /etc/networks
/usr/subnet1 -access=@192.5 #clients must be in the 192.5.0.0 subnet
/usr/domain -access=.myd.myc.com #clients must be in .myd.myc.com
/usr/restrict -access=-host1.myd.myc.com:sales # disallow -host1 in the sales netgroup.

Regards
Sunny
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

Thanks, but here's my issue. UNIX lately has been giving me chest pains. My current /etc/exports file on the NFS server side contains the line:

/backup -anon=65534,access=rp8420:dr8420

It was the dr8420 that was having the problem. Would anyone know the proper line to put in that would automate that, so the chest pains will go away, and I can stop crying? ;)
Should have been an astronaut.
Sunny123_1
Esteemed Contributor

Re: nfs mount - permission denied!

Why you dont add the new line like following

/backup -anon=65534,access=rp8420:dr8420
/backup -anon=65534,access=dr8420

Regards
Sunny
Dags
Frequent Advisor

Re: nfs mount - permission denied!

/etc/fstab <- this will help you automate the mounting.
SUDHAKAR_18
Trusted Contributor

Re: nfs mount - permission denied!

Hi,

create a file which contain following lines..

exportfs -i -o root= /filesystem
exportfs -i -o root= /filesystem

then run this using sh.

then forget about the /etc/exports.
whenever U want to export the filesystem use this script.
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

Thanks for the tips!! What would be the way to automate that upon reboot? We reboot our production system, and the 2 systems that mount the directory once a month.

I imagine that there should be a sequence of reboot too.
Should have been an astronaut.
Sunny123_1
Esteemed Contributor

Re: nfs mount - permission denied!

Just make an entry in /etc/fstab of your filesystem.
Hope this will help.

Regards
Sunny
Ron Irving
Trusted Contributor

Re: nfs mount - permission denied!

Sunny,

The entry in the /etc/fstab doesn't seem to help on the DR system. It's identical to the one on the production side, and it works there.
Should have been an astronaut.
Sunny123_1
Esteemed Contributor

Re: nfs mount - permission denied!

You can make entry in your .profile like below

exportfs -i -o root= /filesystem

So whenever you login the filesystem will be exported

Regards
Sunny