System Administration

Re: nfs mount stopped working (hp ux 11.23)

 
SOLVED
Go to solution
Dennis Handly
Acclaimed Contributor

Re: nfs mount stopped working (hp ux 11.23)

>actually I do use CDE.

But not on the console.

>I assume the management port would be a better way to shutdown and restart the server

Yes, much.

>is there anyway of displaying what the actual mount command looked like when it was created?

Well, if it is mounted on boot, then you can look at /etc/fstab.
Or you can look at /etc/mnttab. Or must type mount to format /etc/mnttab.

>I created an nfs mount using a mount -F nfs -o hard... but I can't remember the full construction of the command or where it might be located?

If you did this manually on a previous boot, this is lost, unless it is around in your shell history file.
Donald Thaler
Super Advisor

Re: nfs mount stopped working (hp ux 11.23)

somehow i lost the nfs mount again, but this time doing the stop and start on the client,server and core didn't help.. when i do a showmount -e i see:
/u06/ldif (everyone)
/u06/rman_backup (everyone)

a showmount -a:
(anon):/u06/ldif
(anon):/u06/rman_backup
sc0gllb1.lccc.edu:/u06/TEST_NSF


but when i try to access them from my other server it tells me the nfs server is not responding...

i've done an exportfs -a...

i modified some kernal entries, but haven't rebooted yet... would this somehow affect the nfs mount ??

is there something else i can look at that would give me a clue as to what's going on

Donald Thaler
Super Advisor

Re: nfs mount stopped working (hp ux 11.23)

i did an nfsstat -m and it returned the specs that i used to create the nfs mount:
nfsstat -m
/u03/rman_restore from apollo:/u06/rman_backup (Addr 10.2.2.20)
Flags: vers=3,proto=tcp,auth=unix,hard,printed,intr,noac,link,symlink,devs,rsize=32768,wsize=32768,retrans=5
TwoProc
Honored Contributor

Re: nfs mount stopped working (hp ux 11.23)

Donald, you can get that error when an NFS mount point gets extremely busy. You may not have enough bandwidth to do what it is you're doing there. There are also proper ways to get mounts working that minimize the amount of traffic needed to keep that connection sync'd up. Please do use and read the book that Bill Hassell told you about, I have it and it does make it much easier to understand what it is you're trying do, and how to do it better.

How does your networking look?
We are the people our parents warned us about --Jimmy Buffett
Donald Thaler
Super Advisor

Re: nfs mount stopped working (hp ux 11.23)

the mount points are not busy... they are used sporadically in a strictly test environment... as far as How does your networking look? i'm not sure what you'e looking for.. all the servers are on a local domain.. the nfs mount was created on our production server, and our backup server attempts to read files from the nfs mount... this used to work, and then it stopped working..?? i'll look for that book... i just thought being a novice at nfs maybe there was some simple process i missed in addition to stopping and starting the nfs client,core,server..
Donald Thaler
Super Advisor

Re: nfs mount stopped working (hp ux 11.23)

if you stop the nfs server, then kill
sfsktcpd, then restart the nfs server the nfs mount comes back ???
TwoProc
Honored Contributor

Re: nfs mount stopped working (hp ux 11.23)

So, this production server interface that you're connecting to - it's not busy? Even if your client connection isn't busy itself, the physical port on production that is hosting your nfs server may be, and if it gets overloaded at peaks of the day, then you'd see what you're seeing.
We are the people our parents warned us about --Jimmy Buffett