cancel
Showing results for 
Search instead for 
Did you mean: 

ninode kernel value

 
Jose Mosquera
Honored Contributor

ninode kernel value

We have a VMGuest machine running on 11iv3.

 

# machinfo
CPU info:
 12 Intel(R)  Itanium(R)  Processor 9350s (1.73 GHz, 6 MB)
          2.39 GT/s QPI, CPU version E0

Memory: 28026 MB (27.37 GB)

Firmware info:
   Firmware revision:  04.30.00
   FP SWA driver revision: 1.18
   IPMI is supported on this system.
   BMC firmware revision: 4.1e

Platform info:
   Model:                  "ia64 hp server Integrity Virtual Machine"
   Machine ID number:      2ba29fb2-b854-11e0-8718-b499ba645408
   Machine serial number:  VM01130004

OS info:
   Nodename:  ---------
   Release:   HP-UX B.11.31
   Version:   U (unlimited-user license)
   Machine:   ia64
   ID Number: ---------
   vmunix _release_version:
@(#) $Revision: vmunix:    B.11.31_LR FLAVOR=perf

 

 

Reviewing the current kernel settings I've noticed an particular behavior on ninode value. At present machine have configured the 60096 value on ninode parameter:

#kctune -d ninode

Tunable  Value  Expression

    Description

ninode   60096  60096

    Maximum number of HFS file system open inodes that can be in memory.

 

By other way, when I run kcusage the following values are displayed:

#kcusage ninode

Tunable                 Usage / Setting

=============================================

ninode                   2346 / 508439

 

As you can see the setting value is 579903 instead 60096!

 

So, when I execute sar -v the fllowing values are displayed:

# sar -v 1 10

 

HP-UX produ2 B.11.31 U ia64    11/22/11

 

14:33:04 text-sz  ov  proc-sz  ov  inod-sz  ov  file-sz  ov

14:33:05   N/A   N/A 916/7000  0  2730/508439 0  16508/2147483647 0

14:33:06   N/A   N/A 916/7000  0  2729/508439 0  16506/2147483647 0

14:33:07   N/A   N/A 916/7000  0  2729/508439 0  16506/2147483647 0

14:33:08   N/A   N/A 916/7000  0  2729/508439 0  16507/2147483647 0

14:33:09   N/A   N/A 916/7000  0  2729/508439 0  16507/2147483647 0

14:33:10   N/A   N/A 915/7000  0  2729/508439 0  16500/2147483647 0

14:33:11   N/A   N/A 915/7000  0  2729/508439 0  16500/2147483647 0

14:33:12   N/A   N/A 915/7000  0  2729/508439 0  16500/2147483647 0

14:33:13   N/A   N/A 915/7000  0  2729/508439 0  16500/2147483647 0

14:33:14   N/A   N/A 915/7000  0  2729/508439 0  16499/2147483647 0

 

At this point the inod-sz is the same that kcusage value (508.439). I'm really confused by this situation. How I can controll the real value of ninode at kctune session?

 

Also I can see a highest value of file-sz (2.147.483.647) How I can set a discrete value?

 

We are trying to get free memory. Please find attached a file with kctune dump.

 

Thanks in advance

1 REPLY
Bill Hassell
Honored Contributor

Re: ninode kernel value

ninode has been historically messed up as a setting sine before version 10. Always override ninode with a fixed value of 4096 or 8192. The formula is worthless and creates a massively large table in the kernel that will never be used.



Bill Hassell, sysadmin