cancel
Showing results for 
Search instead for 
Did you mean: 

nis or automount issue

SOLVED
Go to solution
Douglass A Anderson
Frequent Advisor

nis or automount issue

I am running Nis and I am starting to get the error on some servers. I think it is a nis or automount error.

mkdir: cannot create /h/: Function is not available.

HPUX11iV1 on server and client.

Please help.
10 REPLIES
TTr
Honored Contributor
Solution

Re: nis or automount issue

Where do you get this error? Is it in a log or email?
Douglass A Anderson
Frequent Advisor

Re: nis or automount issue

when a nis user logs in
TTr
Honored Contributor

Re: nis or automount issue

Check the system and user profiles to see what gets executed during login and look for an mkdir command. Is /h/ the user's home directory as it appears in the password map? Why would mkdir be run on it? Unless I am missing something about automounter, there is a typo somehwere or one of the start up files got edited with the wrong command in them.
Douglass A Anderson
Frequent Advisor

Re: nis or automount issue

where are the start up scripts you mention. ?
TTr
Honored Contributor

Re: nis or automount issue

It depends on the shell the users have; for korn/posix shells they are /etc/profile and /.profile. There could be other scripts that are called by these two.
Douglass A Anderson
Frequent Advisor

Re: nis or automount issue

after further checking it looks like the NIS master is not pushing out the netgroups.

how do I check this? is there an error log?
TTr
Honored Contributor

Re: nis or automount issue

Why do you say that?
Look in your master server at /var/yp/ypserv.log.
Douglass A Anderson
Frequent Advisor

Re: nis or automount issue

root@ken26 # ypcat -x
Use "passwd" for map "passwd.byname"
Use "group" for map "group.byname"
Use "networks" for map "networks.byaddr"
Use "hosts" for map "hosts.byaddr"
Use "protocols" for map "protocols.bynumber"
Use "services" for map "services.byname"
Use "aliases" for map "mail.aliases"
Use "ethers" for map "ethers.byname"
TTr
Honored Contributor

Re: nis or automount issue

Do you use netgroup NIS map? You probably don't need one. Is ther a /etc/netgroup file on the NIS master?

Did you check the /etc/profil and .profile files?
Douglass A Anderson
Frequent Advisor

Re: nis or automount issue

fixed /etc/auto_home