Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
cancel
Showing results for 
Search instead for 
Did you mean: 

not login by using telnet

SOLVED
Go to solution
S.S.
Super Advisor

not login by using telnet

Hi,

For one of my server i was unable to login by using telnet session as even though i have given right userid and password also. There is no problem when i supplied the same userid and password by using ssh protocol.
May i know what will the problem?

Thanks!
19 REPLIES
Horia Chirculescu
Honored Contributor

Re: not login by using telnet

Hello,

> There is no problem when i supplied the same userid and password by using ssh protocol.

Then just forget about telnet protocol! ssh is safer, and telnet should be disabled as it send passwords in clear over the network.

Horia.
Best regards from Romania,
Horia.
Johnson Punniyalingam
Honored Contributor

Re: not login by using telnet

telnet, blocked,

you can also check by checking on the

/etc/inetd.conf
/etc/services
Problems are common to all, but attitude makes the difference
S.S.
Super Advisor

Re: not login by using telnet

Hi,

We have checked the /etc/inetd.conf file and we specifically not disabled this service as this is needed for our operation.

Please find the telnet service in /etc/inetd.conf file:

telnet stream tcp nowait root /usr/lbin/telnetd telnetd -b /etc/issue

The banner is working but when i supplied my authentication it displayed the message like login failed.


Thanks!
S.S.
Super Advisor

Re: not login by using telnet

Also, checked the file /var/adm/inet.sec file and the telnet service is allowed.

Thanks!
Horia Chirculescu
Honored Contributor

Re: not login by using telnet

Please post here the result of a telnet session.

Telnet from the local server is working? (I mean ssh to the server then telnet localhost is working?)

Horia.
Best regards from Romania,
Horia.
thatiraju
Frequent Advisor

Re: not login by using telnet

>>>>>>>i was unable to login by using telnet session as even though i have given right userid and password also. There is no problem when i supplied the same user id and password by using ssh protocol.<<<<<<<,]

Here is one cause :
Dear the problem may occur when u use the symbols like $,@ ,∧ # . If u have used these symbols in your passwd your system may not allow you to login through telnet .

The SSH will be working with the same passwords.

We had the same problem too . So please try to avoid the use of these ,
We had a same problem too . I was not aware what to do exactly , but suggested not to use these letters .

Dear Expertise , Could some one tell me why this occurs when we use these symbols .

Raj..



Matti_Kurkela
Honored Contributor
Solution

Re: not login by using telnet

When the first Unix systems were developed, only the most expensive terminals had a CRT display. The rest had a printer instead.

On a printing terminal, erasing a previous character is difficult and slow to do. Therefore, the standard convention was that the "#" character meant "disregard previous character", and "@" meant "disregard the entire line and start over". For example, if a terminal printout line read:

login: mike####sam

it meant the user had first typed "mike", then erased it and typed "sam" instead.
If the other special character was used, it might have looked like this:

login: mike@
sam

The support for these functions was built into the TTY driver. The default settings for the TTY driver were standardized in "System V Interface Definition, Third Edition" (SVID3).

Even though printer terminals can now be found in museums only, the default values of the HP-UX TTY driver have not been changed. The defaults are even documented: see "man 7 termio" on a HP-UX system, and find the sub-title "Special Characters".

These same defaults are used with "pseudo-TTYs" or pty devices, which are used to emulate the interface of a real terminal when using a telnet or SSH connection... unless the telnetd or sshd daemon configures the pty device differently.

The above-mentioned two characters "#" and "@" usually cause the most trouble when logging in.

But when logging in from a console, modem line or any other serial-connected terminal, there is yet another set of special characters to consider.

"getty" is the process that monitors a serial-connected terminal and produces the login prompt. On HP-UX, the man page for getty includes this:

-----
getty also understands the ``standard'' ESS2 protocols for erasing, killing and aborting a line, and terminating a line. If getty sees the ESS erase character, _, or kill character, $, or abort character, &, or the ESS line terminators, / or !, it arranges for this set of characters to be used for these functions.
-----

Most users aren't aware of this functionality, because after the user has been authenticated, the standard login scripts will reconfigure the TTY special characters to values more suitable with less-ancient hardware.

SSH was developed in the 1990s when the network connections were already the norm. Because sshd "knows" the client-side is reasonably modern, OpenSSH initializes the pseudo-TTY with a more modern set of default values, so the characters like "#" and "@" won't be an issue with it.

MK
MK
S.S.
Super Advisor

Re: not login by using telnet

Dear All,

I have used only 1 capital letter and numbers in the password. There is no special character.
The same password i am using for other hosts and they are logging fine via telnet only the problem with one host.

Can anyone suggest me what will be the problem?

I have checked the inetd.conf, inetd.sec file and confirmed that the telnet service is not disabled.

Thanks!
S.S.
Super Advisor

Re: not login by using telnet

Dear All,

I have used a test user to login via telnet and given the same password to login which i am using for my account and it was working fine for the test user.

May i know why login problem only for my account?
Please find the telnet login messages when loging using my account.

login:
Password:
Last successful login for SN95599: Thu Mar 11 08:42:32 SST-8 2010 on pts/ta
Last unsuccessful login for SN95599: Wed Mar 10 16:57:05 SST-8 2010 on pts/ta
Exceeds number of logins allowed (3) for user SN95599

Wait for login exit: ..


Connection to host lost.


Thank you!
Patrick Wallek
Honored Contributor

Re: not login by using telnet

>>Exceeds number of logins allowed (3) for user SN95599

This appears to be the problem. It thinks you are already logged in 3 times and that is the limit.
S.S.
Super Advisor

Re: not login by using telnet

Hi Patrick,

How can we resolve this?


Thank you.
Patrick Wallek
Honored Contributor

Re: not login by using telnet

>>How can we resolve this?

Log out of some sessions, perhaps.

I believe there is a setting in /etc/default/security that can control the number of logins you are allowed. You may want to check that file as well.

Johnson Punniyalingam
Honored Contributor

Re: not login by using telnet

As adviced by >>Patrick Wallek

Check below under the security file)
parameter (NUMBER_OF_LOGINS_ALLOWED=0)in /etc/default/security

>>How can we resolve this?<<

by increasing LOGINS_ ALLOWED counts,
hope it may be "Audit Security" concern, :)

Are you supporting for any "Gov..?? Projects" usually we have these kind of settings , while handling Government Project :)
Problems are common to all, but attitude makes the difference
madhuchakkaravarthy
Trusted Contributor

Re: not login by using telnet

hi

if ur system is trusted

then try out with

/usr/lbin/modprpw -k username

change the values in /etc/default/security.but that depends on ur setup.

if not trusted passwd -d username

if u had settings as not to accept null passwd
then use passwd -f username. u can use the -f option both in trusted & untrusted system.

S.S.
Super Advisor

Re: not login by using telnet

Yes patrick and Johnson, you are right. we have /var/default/security file eventhough our system is converted to trusted and having the entry "NUMBER_OF_LOGINS_ALLOWED=3", so 3 times of logins allowed right.
May i know, is that i didn't exit the telnet session's properly previously? or else i tried morethan 3 times to logon?
Don't have problem when using the ssh session.

When i changed this parameter value to 0 then i am able to logon.

Patrick Wallek
Honored Contributor

Re: not login by using telnet

>>May i know, is that i didn't exit the telnet session's properly previously?

Yes, that is entirely possible.

If you do a 'who' does your username show up more than once? If so, the system still things you are logged in.
thatiraju
Frequent Advisor

Re: not login by using telnet

Thanks Matti Kurkela .....I got my doubt cleared ...

Thanks a lot..

Raj..
Horia Chirculescu
Honored Contributor

Re: not login by using telnet

SS, wouldn't be better to send the info first? It is very important to understand the problem.

>Exceeds number of logins allowed (3) for user SN95599

Most of the users say "This is not working." And ask for help like this:
"Why it is not working?"

Horia.
Best regards from Romania,
Horia.
S.S.
Super Advisor

Re: not login by using telnet

I have understood the problem. Thank you for clearing me.

Many thanks to all reponding to my thread.