cancel
Showing results for 
Search instead for 
Did you mean: 

opening port 1521

AVV
Super Advisor

opening port 1521

Hi All,

I need the port 1521 in my RHEL 5.3 server to be opened inorder to set up an oracle.

I have my iptables and selinux diabled. But I could not "telnet IPAddress 1521" from server .


[root@ora~]# telnet 172.16.30.230 1521
Trying 172.16.30.230...
telnet: connect to address 172.16.3.220: Connection refused
telnet: Unable to connect to remote host: Connection refused


[root@ora ~]# telnet 127.0.0.1 1521
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.
[root@ora ~]#
13 REPLIES
Michal Kapalka (mikap)
Honored Contributor

Re: opening port 1521

hi,

check if you have a firewall enabled ???

if yes you should make a exeption for the 1521 port.

mikap
Michal Kapalka (mikap)
Honored Contributor

Re: opening port 1521

hi,

i forgot :

check if the port 1521 is opened for any connection :

netstat -na |grep -i listen |grep 1521

mikap
Horia Chirculescu
Honored Contributor

Re: opening port 1521

Hello,

The listner is listening on port 1521?

Maybe you have a problem and your listner is dead.

Horia.
Best regards from Romania,
Horia.
Jean-Luc Oudart
Honored Contributor

Re: opening port 1521

Hi

Are these the right IP addresses ?
=======================================
[root@ora~]# telnet 172.16.30.230 1521
Trying 172.16.30.230...
telnet: connect to address 172.16.3.220: Connection refused
=======================================
30.230 vs 3.220 ???

1) have you configured your listener (default port 1521) on the machine

2) can youn post the output of :
"lsnrctl status" command

3) if the listener is up and running , run the "tnsping " (entry name as your tnsnames.ora config file) and post the output.
Check your listener log file.

Oracle product and version ?

Rgds
Jean-Luc
fiat lux
AVV
Super Advisor

Re: opening port 1521

[root@ora etc]# netstat -na |grep -i listen |grep 1521
tcp 0 0 127.0.0.1:1521 0.0.0.0:* LISTEN
[root@ora etc]#

---------
lsnrctl status is not working in the system
---------
Firewall is disabled also selinux too
======
Steven Schweda
Honored Contributor

Re: opening port 1521

> telnet: connect to address 172.16.3.220: Connection refused

"Connection refused" normally means that
there is no one listening at that port.

> [...] to set up an oracle.

Disabling the firewall for a port does not
run any Oracle software.
AVV
Super Advisor

Re: opening port 1521

HI Steven,

What are you meant by. Do our ORACLE person has to set this up ...All everything ok from system side now ?
Steven E. Protter
Exalted Contributor

Re: opening port 1521

Shalom,

Connection refused means one of two things.

1) Firewall is blocking.
2) No service is listening on port 1521

1521 is a port commonly used by the Oracle Database. Oracle does not show the good manners to put an entry in /etc/services to reserve the port.

iptables -L

Look for a firewall rule or general rule blocking traffic. Consider changing the firewall to permit the traffic.

netstat -an | grep 1521

See if there is a service listening on port 1521. If not, see if you can start that service.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Steven Schweda
Honored Contributor

Re: opening port 1521

> [...] Do our ORACLE person has to set this
> up ... [...]

Apparently.

> All everything ok from system side now ?

Perhaps. I'd expect a different complaint
if a firewall of some kind were blocking the
port.

> 2) can [you] post the output of :
> "lsnrctl status" command

> lsnrctl status is not working in the system

"Is not working" is not a useful problem
description. It does not say what you did.
It does not say what happened when you did
it.
Elko
Frequent Advisor

Re: opening port 1521

please enable ip tables :)

1 ) check does anything listen on port 1521, guys already described how to do it

2) open port 1521 on redhat 5 use as root

system-config-securitylevel

small window will open, then "other ports " and add port 1521.

Hope this helps

Regards,
Elko
/home/BIH/Sarajevo
Elko
Frequent Advisor

Re: opening port 1521

Wilfred Chau_1
Respected Contributor

Re: opening port 1521

What is the HOST set to the listener.ora file?

Try change it to 172.16.30.230 and restart the listener.

AVV
Super Advisor

Re: opening port 1521

Thanks