cancel
Showing results for 
Search instead for 
Did you mean: 

/opt

 
RAKUNTA
Frequent Advisor

/opt

hi friends

we are using hp-ux lli v3 , in one V-par /opt is gone to 100% .please advise me what i have to do ?

thanks & regards
rakunta
8 REPLIES
Hakki Aydin Ucar
Honored Contributor

Re: /opt

Hi,

You have two options in generally;

1-delete OR backup,then,delete unnecassry files in /opt

2-extend the file space in /opt ; if you have online JFS it is easy but if you do not have it it needs some workaround, bot possible.
RAKUNTA
Frequent Advisor

Re: /opt

dear hakki ,

can you give me a brief idea on your second step.
Horia Chirculescu
Honored Contributor

Re: /opt

Run:
/usr/sbin/swlist -l product | grep -i jfs

If you have OnLineJFS, then you can do this without booting in single user mode (requires a restart), by only running

lvextend -L then call fsadm to adjust the new size of the FS.

Best regards,
Horia.



Best regards from Romania,
Horia.
Hakki Aydin Ucar
Honored Contributor

Re: /opt

First use recommendation from Horia;
check if you have Online JFS :
# /usr/sbin/swlist -l product | grep -i jfs
let us know if you have first.
singh sanjeev
Trusted Contributor

Re: /opt

check for the large file/ if possible try to do housekeeping

-check space in vg00
-if free PE are there u can hvae option of extending the FS /opt.

Sanjeev Singh
RAKUNTA
Frequent Advisor

Re: /opt

thanks for all

RAKUNTA
Frequent Advisor

Re: /opt

hi i found the solution from forum mates,so iam closing this thread
Bill Hassell
Honored Contributor

Re: /opt

There are always 2 steps to extending a filesystem:

1. lvextend
2. extendfs or fsadm -b

Step 1 just makes the lvol bigger. The fielsystem is unchanged.

Step 2 depends on whether you have Online JFS (an optional purchased package) installed. Check the man page for fsadm_vxfs. If it shows the -b option, then you have the extra package and you can extend the filesystem without rebooting into single user mode to umount /opt. Use fsadm first using the -b newsize option. newsize must be followed by the letter m as in:

fsadm -b 500m /opt

for 500MB as the new size for /opt.

NOTE: after years of reporting that the man page for fsadm_vxfs, you must use the suffix m or M to indicate megabytes. Without the suffix, fsadm uses a useless number called sectors which is undefined. It might be 512 or maybe 1024 and perhaps with trial and error you could figure it out. But if you want megabytes, leaving off the "m" will SHRINK the filesystem (or at least try to...).

Without the optional package, you must umount /opt and run extendfs. Since /opt will be busy, you'll need to reboot, interrupt the boot process and manually boot into single user mode. Then you can run extendfs for the rlvol file:

extendfs /dev/vg00/rlvol#

(rlvol# should be replaced with the correct rlvol number for your system). Then you can type the command reboot and the system will reboot with the new size.


Bill Hassell, sysadmin