cancel
Showing results for 
Search instead for 
Did you mean: 

package startup failed

arun khatwani
Frequent Advisor

package startup failed

I got the following error while starting packages


Cannot lock "/etc/lvmconf/lvm_lock" still trying ...
Cannot lock "/etc/lvmconf/lvm_lock" still trying ...vgchange: Warning: Couldn't attach to the volume group physical volume "/
dev/dsk/c12t0d0":
The path of the physical volume refers to a device that does not
exist, or is not configured into the kernel.
vgchange: The path of the physical volume refers to a device that does not
exist, or is not configured into the kernel.
vgchange: The path of the physical volume refers to a device that does not
exist, or is not configured into the kernel.
vgchange: The path of the physical volume refers to a device that does not
exist, or is not configured into the kernel.
vgchange: Activation mode requested for the volume group "/dev/vgaaa_1" conflicts with configured mode.
vgchange: Warning: couldn't query physical volume "/dev/dsk/c12t0d0":
The specified path does not correspond to physical volume attached to
this volume group
vgchange: Warning: couldn't query physical volume "/dev/dsk/c14t0d0":
The specified path does not correspond to physical volume attached to
this volume group
vgchange: Warning: couldn't query physical volume "/dev/dsk/c13t0d0":
The specified path does not correspond to physical volume attached to
this volume group
vgchange: Warning: couldn't query physical volume "/dev/dsk/c15t0d0":
The specified path does not correspond to physical volume attached

then reboot was done on system n then vg was activated manually,n then packages atartup scipt was run
then log :

May 3 08:57:48 - Node "myhp01": Activating volume group vgaaa_3 with exclusive option.

Cannot lock "/etc/lvmconf/lvm_lock" still trying ...
Cannot lock "/etc/lvmconf/lvm_lock" still trying ...Activated volume group in Exclusive Mode.
Volume group "vgaaa_1" has been successfully changed.
Activated volume group in Exclusive Mode.
Volume group "vgaaa_3" has been successfully changed.

than it got stucked here for 15 to 20 minute not going ahead, it was done 2 time but same error after eevry attempt no success.
3 REPLIES
Prashanth Waugh
Esteemed Contributor

Re: package startup failed

Hi Arun ,

Pls check and post the control log file output.

/etc/cmcluster/pkg name/pkg name.cntl.log

Regards
Prashnat
For success, attitude is equally as important as ability
Michal Kapalka (mikap)
Honored Contributor

Re: package startup failed

Hi,

1, did you made any changes on the cluster configuration ???

2, if not, ioscan -fnC disk |grep NO_HW ???
to check if some disk is missing

3, if not diskinfo on the disk that can't query

4, try manual vgchange for each VG included in the cluster configuration

5, them try to start cluster in debug mode

and see in to the logs.

mikap
smatador
Honored Contributor

Re: package startup failed

Hi,

I suggest you the LVM admin guide for 11iv3
http://docs.hp.com/en/5992-4589/5992-4589.pdf
Look at p117 in the section warning and messages, you could see your error and the solution.

There is also a reference to a command dump_lvmtab very interesting which read the lvmtab and permit to know which vgid is associate with a pvid.
I have in a few week a cluster which lose some pv which are share by the SAN between some different cluster. There is no sense of course, this is clearly an error but very hard to troubleshoot.

So let's do first what Michal write, after that you could involve in more troubleshoot scenario

Hope it helps