System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

panic (cpu 0): pciaconfl: unable to configure PCI subsystem

SOLVED
Go to solution
François Brugère
Frequent Advisor

panic (cpu 0): pciaconfl: unable to configure PCI subsystem

Hello All,

After the restore of the root_domain and usr_domain from an ES40 to a GS140, I get this error when I tried to boot the genvmunix :

panic (cpu 0): pciaconfl: unable to configure PCI subsystem

I don't understand why. I join the complete trace of the boot.

Thanks in advance.
4 REPLIES
Michael Schulte zur Sur
Honored Contributor
Solution

Re: panic (cpu 0): pciaconfl: unable to configure PCI subsystem

Hi,

I don't think this will work. You can't copy system from one system to another. I would suggest a clean install. What os release was on the GS140 before? Try boot -fi GENERIC and build a new kernel and generic kernel.

Michael
Ralf Puchner
Honored Contributor

Re: panic (cpu 0): pciaconfl: unable to configure PCI subsystem

you can not use the hardware database etc. from an ES40 on an GS140 (if using Tru64 5.x)! This is totally unsupported.

There is possibly one way to get it running:

1. Set BOOTDEF_DEV to a null string to prevent the installation
process from copying the bad hardware configuraton from the
root filesystem:

>>> SET BOOTDEF_DEV ""

2. Boot the installation CDROM. At the first opportunity, exit
to the UNIX shell. If the console is serial, choose option #3
(Exit Installation.) On a graphics console, pull down the File
menu and select Shell Window.

3. Create a domain link if the root filesystem is AdvFS:

# cd /etc/fdmns
# mkdir root_domain
# cd root_domain
# ln -s /dev/disk/dsk1a (Substitute the appropriate device name)

4. Mount the root filesystem on /mnt:

UFS: # mount /dev/disk/dsk1a /mnt

AdvFS: # mount root_domain#root /mnt

5. Save the old (bad) files:

# cd /mnt/etc
# mkdir save
# cp d* save

6. The new hardware database built by the installation process is
stored in /var/etc, which is part of a memory filesystem. Copy
these files to /mnt/etc.

# cp /var/etc/d* /mnt/etc

7. Halt the system.

# cd /
# umount /mnt
# halt

8. Restore the value of BOOTDEF_DEV and reboot the system.

>>> SET BOOTDEF_DEV DKA100 (Substitute appropriate device)
>>> BOOT

IMPORTANT: This procedure is not a supported way! If this will not solve your problem you must reinstall the system from scratch or restore a backup of the GS140!
Help() { FirstReadManual(urgently); Go_to_it;; }
François Brugère
Frequent Advisor

Re: panic (cpu 0): pciaconfl: unable to configure PCI subsystem

Thanks a lot for your answers.

The OS is V5.1B PK3 in both systems. I try your advice now.

Francois.
François Brugère
Frequent Advisor

Re: panic (cpu 0): pciaconfl: unable to configure PCI subsystem

Finaly, it's not working.
Here is the error message :
Alpha boot: available memory from 0xa7c0000 to 0x17ff58000
Compaq Tru64 UNIX V5.1B (Rev. 2650); Fri May 30 19:14:21 CEST 2003
physical memory = 6144.00 megabytes.
panic (cpu 0): kmem_suballoc: unable to change range to submap

DUMP: Warning: no disk available for dump.

I tried another attempt after deleting the complete hardware database and booting with this command line : boot -fi GENERIC dka0. But il failed again.

I start a fresh install.