cancel
Showing results for 
Search instead for 
Did you mean: 

passwd enabling

 
madhuchakkaravarthy
Trusted Contributor

passwd enabling

ver 11i v1 and its trusted system.

when i check with modprpw lockout value is 100000.

when i tried to enable with getprpw ,i am not able to enable it.when i tried to do with sam and reactivate it ,, sam gives me a password just as .(dot).. when i try to login again with .(dot) access denied.

by root also i cant change passwd.

passwd user

error

password lifetime has passed.

but one of my teammate used passwd -f username

and passwd got enabled. and my doubt is do passwd -f will support if a system is trusted one.... and if passwd -f can do y cant modprpw..

i have tried to do with modprpw as using

modprpw -m alock=NO username

regards

MC
5 REPLIES
madhuchakkaravarthy
Trusted Contributor

Re: passwd enabling

when i tried to enable with getprpw=====>> ,i am not able to enable it.when i tried to do with sam and reactivate it ,,

--------------------


that is with modprpw ,, i have mention it wrongly
Johnson Punniyalingam
Honored Contributor

Re: passwd enabling

>>my doubt is do passwd -f will support if a system is trusted one.... and if passwd -f can do y cant modprpw<<

Yes "passwd -f" will support both in "trusted & non-trusted system"

passwd -f "force to changes use password @ next login" -> man passwd

modprpw -> command use enable "locked account" in trsuted system -> man modprpw
Problems are common to all, but attitude makes the difference
Jupinder Bedi
Respected Contributor

Re: passwd enabling

try as follows

/usr/lbin/modprpw -l -k username

and than

change the password

passwd username

and than do

/bin/passwd -f username


if still not working than send me the output of

/usr/lbin/getprpw -l username


Good Luck
All things excellent are as difficult as they are rare
kashyapi
Frequent Advisor

Re: passwd enabling

I also faced same problem which you faced.Following steps resolved my issue...

#/usr/lbin/modprpw -k username
switch to the user from root ....
#su - username
#passwd
i changed the password of that user and the user was able to login.

Also i ran following command as root which w updates passwd protected database in trusted mode system.
#pwconv
I was able to login to the system using that user.
Then also i was not able to change the the passwd from SAM and it was not showing password.Then i disabled and recreated the user and issue has been resolved.
madhuchakkaravarthy
Trusted Contributor

Re: passwd enabling

i have found the solution,,

txs for all ur info