System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

patch install failed, now receive could not load a.out on reboot

geeze
Occasional Contributor

patch install failed, now receive could not load a.out on reboot

Hello,
I've just been installing a patch PHKL_40240 (with its dependencies). The patch decided to stop at 65% and then the system appeared to crash. I presume the crash lead to it stopping :( The problem now is that I cannot boot into mutli user mode. I just the error "exec(2): could not load a.out" coming up all the time.
If i go into single user mode and try to run vi or more etc then I get this message too. I can load the file systems but am now stuck for what to do next. I am no UNIX guru so appreciate any pointers you can give.
This is on a virtual machine.
Thanks
5 REPLIES
Dennis Handly
Acclaimed Contributor

Re: patch install failed, now receive could not load a.out on reboot

It's probably time to talk to the Response Center.
Do you have an ignite backup?
Don Morris_1
Honored Contributor

Re: patch install failed, now receive could not load a.out on reboot

Given this is core kernel VM, the only things affected should be the VM modules in your running kernel. So I'd look for your backup configurations in /stand (backup, GOOD, last_install -- something along those lines) and boot that instead.

kconfig -n GOOD

if you can do it (substitute whatever configuration is _not_ current you have for "GOOD").

If kconfig won't run either:

hpux GOOD/vmunix

at the boot loader.

Once you get the system in a usable state you'll have to see if it thought the patch installed or not to try to clean up.
geeze
Occasional Contributor

Re: patch install failed, now receive could not load a.out on reboot

Okay, I'm pleased to say that we have resolved this issue :)
The first step was to boot into single user mode. Then from here clean the partitions with fsck. It was still producing the same problems. We couldn't run anything other than the built in commands pointing us to the fact that maybe there was an issue with some of the library files.
we looked at the patches and files that were changed. We found a bunch of zero byte files in one of the directories that the patch was updating. I guess it crashed whilst writing these to the disk. The zero byte files were accompanied by correct sized files that started with a #. we replaced these for the patched files and then re ran the swinstall. forced a reinstall of the patches so that we could ensure it had all the right files.
hey presto, patch applied and the system is fully functional again.
Very pleased.
geeze
Occasional Contributor

Re: patch install failed, now receive could not load a.out on reboot

as above :)
Dennis Handly
Acclaimed Contributor

Re: patch install failed, now receive could not load a.out on reboot

>were accompanied by correct sized files that started with a #.

These are typically the old busy files that would be replaced/removed later.