HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

printer is disabled in lpstat

 
Sri123
Advisor

printer is disabled in lpstat


Hi,

I added a new network printer yesterday. It is showing disabled status in lpstat output. Its nopt enabling even after trying with "enable" command and in SAM.

I have confirmed that the printer is switched on and is ready.

Attached are the lpstat output and the hpnpadmin output.

/etc/hosts is fine as i have already added the printer.

Can someone help me to enable the printer.


Thanks in Advance!
Sridhar
7 REPLIES
Shibin_2
Honored Contributor

Re: printer is disabled in lpstat

Have you check your scheduler running or not ?

lpstat -r
Regards
Shibin
Sri123
Advisor

Re: printer is disabled in lpstat

yes,

it is running. Able to ping the printer IP.

# lpstat -r
scheduler is running
#
# ping 172.25.17.50
PING 172.25.17.50: 64 byte packets
64 bytes from 172.25.17.50: icmp_seq=0. time=1. ms
64 bytes from 172.25.17.50: icmp_seq=1. time=1. ms

----172.25.17.50 PING Statistics----
2 packets transmitted, 2 packets received, 0% packet loss
round-trip (ms) min/avg/max = 1/1/1


# nslookup 172.25.17.50
Using /etc/hosts on: GLBUD

looking up FILES
Name: gl_dl_lj8_1
Address: 172.25.17.50
Sri123
Advisor

Re: printer is disabled in lpstat

This is what is my /var/adm/lp/log shows:

hpnpf: unknown host gl_dl_lj8
disabling gl_dl_lj8_1
gl_dl_lj8_1-852 bnkupg3 gl_dl_lj8_1 Jan 19 08:40
Start: gl_dl_lj8_1-852 Wed Jan 19 08:40:27 uae 2011
End: gl_dl_lj8_1-852 Wed Jan 19 08:40:27 uae 2011
/etc/lp/interface/model.orig/gl_dl_lj8_1 landscape 12 lpi8
/opt/hpnpl/bin/hpnpf -j gl_dl_lj8_1-852+bnkupg3 -a1 -x gl_dl_lj8
hpnpf: unknown host gl_dl_lj8
disabling gl_dl_lj8_1
gl_dl_lj8_1-852 bnkupg3 gl_dl_lj8_1 Jan 19 08:43
Start: gl_dl_lj8_1-852 Wed Jan 19 08:43:51 uae 2011
End: gl_dl_lj8_1-852 Wed Jan 19 08:43:51 uae 2011
/etc/lp/interface/model.orig/gl_dl_lj8_1 landscape 12 lpi8
/opt/hpnpl/bin/hpnpf -j gl_dl_lj8_1-852+bnkupg3 -a1 -x gl_dl_lj8
hpnpf: unknown host gl_dl_lj8
disabling gl_dl_lj8_1
gl_dl_lj8_1-852 bnkupg3 gl_dl_lj8_1 Jan 19 08:44
Start: gl_dl_lj8_1-852 Wed Jan 19 08:44:20 uae 2011
End: gl_dl_lj8_1-852 Wed Jan 19 08:44:20 uae 2011
/etc/lp/interface/model.orig/gl_dl_lj8_1 landscape 12 lpi8
/opt/hpnpl/bin/hpnpf -j gl_dl_lj8_1-852+bnkupg3 -a1 -x gl_dl_lj8
hpnpf: unknown host gl_dl_lj8
disabling gl_dl_lj8_1
gl_dl_lj8_1-852 bnkupg3 gl_dl_lj8_1 Jan 19 08:45
Start: gl_dl_lj8_1-852 Wed Jan 19 08:45:38 uae 2011
End: gl_dl_lj8_1-852 Wed Jan 19 08:45:38 uae 2011
/etc/lp/interface/model.orig/gl_dl_lj8_1 landscape 12 lpi8
/opt/hpnpl/bin/hpnpf -j gl_dl_lj8_1-852+bnkupg3 -a1 -x gl_dl_lj8
hpnpf: unknown host gl_dl_lj8
disabling gl_dl_lj8_1



Any suggestions as what is the problem!!
Sri123
Advisor

Re: printer is disabled in lpstat

HI,

I modified the /etc/hosts from

172.25.17.50 gl_dl_lj8_1 to
172.25.17.50 gl_dl_lj8


Further, i did:

enable gl_dl_lj8_1

Then queue jobs seemed to start and things seems to be file now.


printer gl_dl_lj8_1 is idle. enabled since Jan 19 09:17
fence priority : 0




Is this a permanent fix for this Problem.

Kindly share the suggestions!!


Thanks in Advance,

Sridhar
Shibin_2
Honored Contributor

Re: printer is disabled in lpstat

Looks like, while you installed the printer, you have specified name, instead of IP address. And that name went wrong. Now that you found out solution and corrected. Keep it up.
Regards
Shibin
Rita C Workman
Honored Contributor

Re: printer is disabled in lpstat

One thing you could have done, using HP's
Jetdirect, is to change the LP destination (queue) name and re-enter the name and remove the "_1" and then say OK when you created the printer.

If you make sure the print queue for this one is clear, you could delete the one you have; use Jetdirect and recreate it to remove that "_1".

Rgrds,
Rita
Sri123
Advisor

Re: printer is disabled in lpstat

Thanks