System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

"SCSI error" + "kernel: end_request: I/O error" in /var/log/messages

bullz
Super Advisor

"SCSI error" + "kernel: end_request: I/O error" in /var/log/messages

Hello experts,

I'm seeing the below error logs under the "/var/log/messages" log. All the disks are fine and the LED is flashing green light. I couldn't diagnoise what is causing the problem.

I suspect "dev sdf" is having some problem. Could you please shed some light on this issue.

operating system: Red Hat Enterprise Linux Server release 5.1

/var/log/messages
------------------

Feb 14 23:00:04 localhost kernel: sd 2:0:0:0: SCSI error: return code = 0x00070000
Feb 14 23:00:04 localhost kernel: end_request: I/O error, dev sdf, sector 80949440

2 REPLIES
Ross.Murphy
Occasional Advisor

Re: "SCSI error" + "kernel: end_request: I/O error" in /var/log/messages

Are these SAN connected volumes?
If so, what multipathing are you using?

I see errors like these with EMC stuff a lot.
bullz
Super Advisor

Re: "SCSI error" + "kernel: end_request: I/O error" in /var/log/messages

Hi all,

* Ofcourse, its SAN connected volumes.
* But it's a NETAPP storage.

[root]# multipath -ll
mpath2 (XXXXXXXXXXXXXXXXXXXXXX) dm-9 NETAPP,LUN
[size=50G][features=1 queue_if_no_path][hwhandler=0]
\_ round-robin 0 [prio=8][active]
\_ 4:0:0:1 sdc 8:32 [active][ready]
\_ 2:0:0:1 sdg 8:96 [active][ready]
\_ round-robin 0 [prio=2][enabled]
\_ 4:0:1:1 sde 8:64 [active][ready]
\_ 2:0:1:1 sdi 8:128 [active][ready]
mpath1 (XXXXXXXXXXXXXXXXXXXXXX) dm-8 NETAPP,LUN
[size=50G][features=1 queue_if_no_path][hwhandler=0]
\_ round-robin 0 [prio=8][active]
\_ 4:0:0:0 sdb 8:16 [active][ready]
\_ 2:0:0:0 sdf 8:80 [active][ready]
\_ round-robin 0 [prio=2][enabled]
\_ 4:0:1:0 sdd 8:48 [active][ready]
\_ 2:0:1:0 sdh 8:112 [active][ready]



Is that something wrong with storage path?
Please advise.