System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

"ioscan -fnNC tape" shows devices with "NO_HW"

Sivarama Raju
Frequent Advisor

"ioscan -fnNC tape" shows devices with "NO_HW"

Hello,

 

I did a LUN modification on the EMC DataDomain devices for the HP-UX 11.31 Initiators, on the EMC DataDomain admin console.

 

After this, when I run an "ioscan -fnNC tape" on the HP-UX 11.31 IA 64, all those devices appear with "NO_HW" and the backup application cannot detect the devices.

 

I do not have good experience with this, can anyone please help me with this issue.

 

Please find below a part of the output of command "ioscan -fnNC tape"

 

root@serv001-# /usr/sbin/ioscan -fnNC tape
Class     I  H/W Path  Driver S/W State   H/W Type     Description
===================================================================
tape     20  64000/0xfa00/0x17  estape   NO_HW       DEVICE       IBM     ULTRIUM-TD3
                      /dev/rtape/tape20_BEST    /dev/rtape/tape20_BESTb   /dev/rtape/tape20_BESTn   /dev/rtape/tape20_BESTnb
tape     21  64000/0xfa00/0x18  estape   NO_HW       DEVICE       IBM     ULTRIUM-TD3
                      /dev/rtape/tape21_BEST    /dev/rtape/tape21_BESTb   /dev/rtape/tape21_BESTn   /dev/rtape/tape21_BESTnb


 

Thanks,

Siva

4 REPLIES
RAJD1
Valued Contributor

Re: "ioscan -fnNC tape" shows devices with "NO_HW"

Hi Siva,

Do you see any error with dmesg, 

if yes pls post,  you may have to do lun binding with wwn, with help of scimgr .

 

Cheers,

Raj D.

Ozer YUMSEK
Occasional Advisor

Re: "ioscan -fnNC tape" shows devices with "NO_HW"

Hi Sivarama,

 

#rmsf -x

 

Clears all detached devices.

 

My advice is clear all detached devices because sometimes it gives errors.

 

Then you can

 

#ioscan

 

and

 

#insf -e

 

#ioscan -fnNC tape

 

You will see your tapes there.

 

Regards.

vishnu.khandare
Respected Contributor

Re: "ioscan -fnNC tape" shows devices with "NO_HW"

Hi,

Please check the dmseg, check the drive is On, check drive is proparly connected to scsi.

 

 

Regards

Vishnu

 

You should deserve before U desire!!!!
Torsten.
Acclaimed Contributor

Re: "ioscan -fnNC tape" shows devices with "NO_HW"

Not sure what modification you did.

 

 

Some related messages in syslog?

 

I assume there is an advise to use ‘scsimgr replace_wwid’.

 

Locate the document

 

SCSIMGR - SCSI Management and Diagnostics utility on HP-UX 11i v3

 

and read from page 29 on.

 

 

 

Or just reboot the server.

 


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!