System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

rcmd:connect:hostname:connection refused

 
SOLVED
Go to solution
stephen peng
Valued Contributor

rcmd:connect:hostname:connection refused

dear all,
I've search the forum for this issue, but did not find any thread to exactly explain the cause.
I've got two nodes in a cluster, they could remsh or rlogin to each other. but when i tried to rcp, it posted: rcmd:connect:hostname:connection refused.

this should be related to /etc/services or /etc/inetd.conf, i really want to know which service was related to rcp.

attached file is their /etc/services and /etc/inetd.conf,maybe just un-comment some lines and restart inetd will fix the issue.

thanks a lot
2 REPLIES
Steven Schweda
Honored Contributor
Solution

Re: rcmd:connect:hostname:connection refused

As usual, it might be helpful to show actual
commands with actual error messages instead
of vague descriptions and interpretations.

And start with "uname -a".

> [...] they could remsh or rlogin [...]

"remsh" with a command? For example:

remsh host_name 'pwd'

Without a command, remsh and rlogin may be
more similar than you realize.

> # shell [...]

I'd try that one.

> [...] i really want to know which service
> was related to rcp.

And a Web search for keywords like, say,
rcp service
didn't help?
stephen peng
Valued Contributor

Re: rcmd:connect:hostname:connection refused

S.S.,
1,yes I just tried to rlogin using remsh, not to run a command remotely.
2,I agree with you about uncomment # before shell, though i did not try it yet.
3,I could not get some useful information about searching rcp+service, maybe just before of my poor english reading.

thanks a lot