System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

rcp or rsh gets Warning: User disk quota exceeded.

Jim Giles
Advisor

rcp or rsh gets Warning: User disk quota exceeded.

I do not have quota running anywhere but get this error when trying to use a specific account on the remote host. I have the .rhosts file configured correctly because I can do the rlogin without password.

Any clue would be appreciated.

10 REPLIES
Jim Giles
Advisor

Re: rcp or rsh gets Warning: User disk quota exceeded.

I probably should add I am running 5.1B pk4 Tru64 on both systems. I am running tcp wrappers and this function was working until recently. I have no clue what I may have changed to make this stop working.
Ivan Ferreira
Honored Contributor

Re: rcp or rsh gets Warning: User disk quota exceeded.

Even if you don't have quota enabled, try running quotacheck.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Jim Giles
Advisor

Re: rcp or rsh gets Warning: User disk quota exceeded.

THanks but I have ran the quotacheck on all mount points. That did not help.

Please keep talking. I have been working on this for two days.
Ivan Ferreira
Honored Contributor

Re: rcp or rsh gets Warning: User disk quota exceeded.

Maybe that is just a warning (a wrong warning, and it seems to be from the source host), is that the only message that you have. You have that message when you run rsh remotehost ls? does the command works or you get time out or error.

Have you tried with ftp, scp? (just for test)
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Jim Giles
Advisor

Re: rcp or rsh gets Warning: User disk quota exceeded.

ftp works, I have not tried scp.

I have tried ssh to call a remote ps -aef and that works if I enter the password. I don't have the .shosts file working for the ssh interface yet to enable functioning without a password.

Ivan Ferreira
Honored Contributor

Re: rcp or rsh gets Warning: User disk quota exceeded.

Is better if you configure a public key without passphrase for this purpose. Use ssh-pubkeymgr. See the man page for more details. Remember that the key must not have a passphrease, execute the command on the source host.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Jim Giles
Advisor

Re: rcp or rsh gets Warning: User disk quota exceeded.

I still have the quota error message coming back with one specific account when doing an rsh.

I have ran quotacheck -v on all file systems and find no problems.

Any other ideas would be appreciated.
Jim Giles
Advisor

Re: rcp or rsh gets Warning: User disk quota exceeded.

Just for the record, and in case someone else has this problem. I never found a solution or reason for this.

I changed the UID number of the problem account by deleting the account without removing any files, creating the account with a new UID#, using find with -user and -exec options to change the ownership of old files to the new UID.

Problem solved. I give me 10 points.
Jim Giles
Advisor

Re: rcp or rsh gets Warning: User disk quota exceeded.

See above
Ivan Ferreira
Honored Contributor

Re: rcp or rsh gets Warning: User disk quota exceeded.

Good job, I give you another 10 points!!! Thanks for the feedback.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?