System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

rlogin is working but remsh is not working

SOLVED
Go to solution
senthil_kumar_2
Regular Advisor

rlogin is working but remsh is not working

Hi

i am able to rloin system1 from system10 with out prompting for password. but i am not able to run remsh in separate or in script.

I am getting following error when trying to run remsh from system10

Ex:

root@system10:/root > remsh system1 -n grep ze4egi /etc/passwd
remshd: Login incorrect.


But i am able to rlogin in to system10 successfully.

inetd.conf file of system 1

login stream tcp nowait root /usr/lbin/rlogind rlogind
shell stream tcp nowait root /usr/lbin/remshd remshd
exec stream tcp nowait root /usr/lbin/rexecd rexecd


How to solve this problem



10 REPLIES
Pete Randall
Outstanding Contributor
Solution

Re: rlogin is working but remsh is not working

Same suggestion as your other rlogin question: Have you verified that root's home directory is set to the same location in both /etc/passwd files?


Pete

Pete
Mel Burslan
Honored Contributor

Re: rlogin is working but remsh is not working

Since you seem to be doing a lot of remote operations, I need to reinforce my suggestion of using ssh instead of the insecure r- daemons, as in rexecd, remshd.

You will realize, life is much simpler once you set up your working key pairs.
________________________________
UNIX because I majored in cryptology...
Suraj K Sankari
Honored Contributor

Re: rlogin is working but remsh is not working

Hi,

Did you checked inetd.sec file ?

inetd.sec is a file that can be used to restict access of inetd services (ftp, telnet, rlogin etc) to particular networks. The file is found at /var/adm/inetd.sec. If this file does not exist then inetd services are open to all ip addresses.

Suraj
senthil_kumar_2
Regular Advisor

Re: rlogin is working but remsh is not working

what is the format of this file.
Steven E. Protter
Exalted Contributor

Re: rlogin is working but remsh is not working

Shalom,

Answer to your last query:
http://docs.hp.com/en/B2355-60105/inetd.sec.4.html

http://docs.hp.com/en/B2355-90685/ch02s04.html

http://docs.hp.com/en/B2355-90774/ch02s02.html

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Kranti Mahmud
Honored Contributor

Re: rlogin is working but remsh is not working

Hi Senthil,

If system1 to system10 does not work then the issue is on system10.
Many things need to happen on system10.

1) remsh needs to be configured in inetd.conf
2) if inetd.sec is being used then remsh needs to be allowed from system1 and others.
3) .rhost file on system10 must be configured properly. If using hostnames then /etc/hosts must be configured correctly for system1.
4) If there is a firewall between system1 and system10 then the firewall needs to be configured correctly.
5) What are the permissions on the .rhosts file on the system10 that is not working? The permissions should be 600 (-rw-------)

Rgds-Kranti
Dont look BACK as U will miss something INFRONT!
avizen9
Esteemed Contributor

Re: rlogin is working but remsh is not working

Hello Senthil,

this document may help you to find out solusion, go through it, thanks,

http://docs.hp.com/en/B2355-90827/ch05s02.html
Suraj K Sankari
Honored Contributor

Re: rlogin is working but remsh is not working

Hi,
see the output of a inetd.sec file

# inetd.sec -- this inetd.sec contains the minimum security needed
# inside HP on the 15 network.
# For the 192.170.74.0 network/netmask 255.255.255.128 (ffffff80)
# entries shoud be similar to this
# telnet allow 127.0.0.1 192.170.74.0-127 15.13.146-147.*
# this will only allow the OSD-15- and the 192.170.74.0/ffffff80-
# networks to use the services.
ftp allow 15.* 127.0.0.1 192.170.74.* 192.170.84.*
telnet allow 15.* 127.0.0.1 192.170.74.* 192.170.84.*
login allow 15.* 127.0.0.1 192.170.74.* 192.170.84.*
shell allow 15.* 127.0.0.1 192.170.74.* 192.170.84.*
exec allow 15.* 127.0.0.1 192.170.74.* 192.170.84.*
omni allow 15.* 127.0.0.1 192.170.74.* 192.170.84.*

Suraj
nightwich
Valued Contributor

Re: rlogin is working but remsh is not working

Hi Kumar !!


First you should put related problems in the same threath !!


second Please check also your /etc/hosts

if you want thas system1 connect to system2 your /etc/hosts of the system2 should look like this:

xx.xx.xx.xx system2.domain.com system2 xx.xx.xx.xx system1.domain.com system1
127.0.0.1 localhost loopback


Best regards !!

senthil_kumar_2
Regular Advisor

Re: rlogin is working but remsh is not working

Hi All,


I am closing this thread.