cancel
Showing results for 
Search instead for 
Did you mean: 

root ftp problem

SOLVED
Go to solution
ats1
Frequent Advisor

root ftp problem

hi all,

how to prevent the root user to (make) the FTP?

Itanium 11iv3
8 REPLIES
Victor Fridyev
Honored Contributor
Solution

Re: root ftp problem

RTFM ftpusers:
ftpusers - security file for ftpd(1M)

DESCRIPTION
ftpd rejects remote logins to local user accounts that are named in
/etc/ftpd/ftpusers.

HTH
Entities are not to be multiplied beyond necessity - RTFM
ats1
Frequent Advisor

Re: root ftp problem

this file does not exist in my system.
in my server i have :
/usr/newconfig/etc/ftpd/examples/ftpusers

root in writing in this file but the ftp is not deny. wht can i do to resolve the problem.
Jim Walls
Trusted Contributor

Re: root ftp problem

That instance of the file is merely an example; it is not the one that ftpd uses.

You must create your own file /etc/ftpd/ftpusers

You may aslo need to restart ftpd to pick up the new file.

Hakki Aydin Ucar
Honored Contributor

Re: root ftp problem

Check out the upload keyword on the ftpaccess man page and in the /etc/ftpd/ftpaccess file.

http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1285325701330+28353475&threadId=1439679
ats1
Frequent Advisor

Re: root ftp problem

i create the new file /usr/newconfig/etc/ftpd/ftpusers. but how can i restart the ftpd deamon?
Bijeesh
Respected Contributor

Re: root ftp problem

Hi,
You should manually create the directory /etc/ftpd and inside this directory create the file ftpusers.Add the usernames in this file to disable ftp for that users.
To restart the the ftp service,
#inetd -c

ats1
Frequent Advisor

Re: root ftp problem

is it the same process for telnet? i want to deny telnet for root only. help me please
bests regards
Bijeesh
Respected Contributor

Re: root ftp problem

Hi,
You can create a file /etc/securetty
and add the word console in it.
#cat /etc/securetty
console

This should work