System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: root login at console not working (is allowed in /etc/security and root password is correct)

 
SOLVED
Go to solution
Greg Taylor
Advisor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

@ Patrick

 

Yessssss!  That was it.  I changed the password and was able to login at the console.  Thanks so much!

 

Now I need to negotiate with security for a root password that doesn't contain a special character or find a special character that does not cause problems.

 

 

Dennis Handly
Acclaimed Contributor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

> Now I need to negotiate with security for a root password that doesn't contain a special character or find a special character that does not cause problems.

 

No need.  You just need to change your fingers.  :-)

The only special chars with problems are "#" and "@".  Under stty, these are backspace and kill.

So you can either not use these two as mentioned under passwd(1), WARNINGS.

 

Or you must escape those chars with "\".

 

Bill Hassell
Honored Contributor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

Every sysadmin needs to raise a flag when security requires special characters. Every operating system will have some quirk due to special characters. I simply demand that they never be allowed so that the same rule will work on all systems -- alphanumeric characters, upper and lowercase.

 

However, you can get the HP-UX system to remove the special meaning for @ and #.  Put this line in /etc/inittab:

 

ttco::bootwait:/sbin/stty intr ^C erase ^H kill ^U < /dev/ttyconf 

 What this does is to configure the tty driver to redefine the archaic definitions for erase and backspace. This is done in /etc/profile but that is too late for login. By setting the value at boot time for the driver, all terminal I/O such as logins will be processed correctly. Put the above line in inittab on all your HP-UX systems. You can then run the command by hand:

/sbin/stty intr ^C erase ^H kill ^U < /dev/ttyconf 

 to set the current tty driver defaults. Now your password can contain @ or # and it will work OK. BUT, as I said, special characters will not work the same on every OS so don't use them..



Bill Hassell, sysadmin
vz7r1x
Regular Advisor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

 

Great analysis.

 

This solved my problem too.  I had @ in my password and caused my MP to fail connection to the HP-UX server.  I removed @ character from the passwordand started working.

 

Thanks

John Dvorchak
Honored Contributor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

What a lot of folks don't know, and this goes back to the days of a "teletype" type mechanical console. I'm talking back in the 70's, is that the @ sign meant "delete to end of line".  So in effect anything after the @ sign is not considered and erased. That is why the @ sysmbol should never be used in a password on an HPUX system.

If it has wheels or a skirt, you can't afford it.
Dennis Handly
Acclaimed Contributor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

>is that the @ sign meant "delete to end of line".

 

That's delete from the beginning of the line.

Bill has told the TTY history much better in one of his other posts.

MIke_Kapsak
New Member

Re: root login at console not working (is allowed in /etc/security and root password is correct)

My issue is a little different with the root login. I am connected serially via a console switch to the serial console port on my rx6600. WHen I telnet to that console port I am able to bring up the MP Main Menu by using <ctrl> b. But when I enter CO for console mode I press return but no console prompt. I get a carriage return each time I press enter. I can go back to the MP menu anytime.

In other words I do not get a login prompt.

Thanks,

Mike Kapsak

Torsten.
Acclaimed Contributor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

Maybe another process is running and block the console? I would try to use ps and grep console.

 

It could help to review the console log from MP too.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Bill Hassell
Honored Contributor

Re: root login at console not working (is allowed in /etc/security and root password is correct)

Something has the console open. The connection from the MP (a separate managment computer inside the rx2660) to HP-UX is through a special port. Whether you use a serial cable or the built-in LAN connection to the console, the CO command takes you directly to the console. With no response (prompt, etc), some process is holding the console connection. 

Start by typing ctrl-c to kill the process. If that doesn't work, type ctrl-\ (ctrl and the backslash or vertical bar). These are the two signal characters that can terminate a process in the current session.

If that doesn't work, from the regular HP-UX LAN connection, login and run this command:

# ps -f -t console

This will show all processes that are using the console. You can then kill the process ID (or multiple IDs). If the process cannot be killed, you use the kill -9 option, but if that doesn't work, the connection is hung on I/O (typically networking) and cannot be killed.

One other possibility: if you used the MP to login to the console, then used an HP-UX command like telnet or ssh to other systems (a very bad idea), you'll need to untangle the leap-frog connections back to your rs2660. Always use the MP -> CO connection for local commands that do not involve other systems.

Rebooting the rx2660 will clear and leap-frog connections and if that faills to clear the CO coonection, you can reset the MP from the MP -> CM menu.



Bill Hassell, sysadmin