HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

root su - oracle prompts for password ??

 
SOLVED
Go to solution
MikeL_4
Super Advisor

root su - oracle prompts for password ??

I have the Oracle startup/shudown script in /etc/init.d: -rwxr-x--- 1 oracle dba 930 May 14 12:57 /etc/init.d/dbora

But when the server is rebooted, it prompts for a password when trying to start up oracle:

ORACLE_HOME=/opt/oracle/product/10.2.0.4
ORA_OWNER=oracle
#
case "$1" in
'start')
# Start the Oracle databases:
# The following command assumes that the oracle login
# will not prompt the user for any values
touch /var/lock/subsys/dbora
sleep 120
su - $ORA_OWNER -c "$ORACLE_HOME/bin/dbstart $ORACLE_HOME"
;;

when I try to su - oracle from command line I get right in as expected....
3 REPLIES
Ivan Ferreira
Honored Contributor
Solution

Re: root su - oracle prompts for password ??

I would try setting root:root as the owner of the script.

I don't know why you have a "sleep 120" after a touch command.

Please add the following command:

id > /tmp/dbora.$$

To check the user credentials that is running the init script.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: root su - oracle prompts for password ??

Shalom,

Could be the pam configuration is preventing su - logins.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
MikeL_4
Super Advisor

Re: root su - oracle prompts for password ??

Thanks for input, but in testing this was a false alarm.... DBA wasn't giving the entire store, and actually the su is working correctly..