cancel
Showing results for 
Search instead for 
Did you mean: 

runlevel

 
Abhiram
Occasional Visitor

runlevel

hi all,
hi in my system init 5 or startx commands are not working.

can anybody help me.



thanx in advance



9 REPLIES
Jeeshan
Honored Contributor

Re: runlevel

check /etc/inittab file.

If you choose post installation which mode you want to login, it will by default login init 3 level.

a warrior never quits
Abhiram
Occasional Visitor

Re: runlevel

hi ashan,
i know that.but my prob. is when i type init 5 in command line it should go to GUI mode. But its not happening.


Ivan Ferreira
Honored Contributor

Re: runlevel

Which Linux distro? Probably you don't have your X settings correct.

Run system-config-display if Red Hat Based.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Abhiram
Occasional Visitor

Re: runlevel

hi,
its fc 7
~sesh
Esteemed Contributor

Re: runlevel

When you type startx or init 5, it will try to bring the x window or graphical system up. If it fails to bring the graphical system up, you would be able to see the error that's preventing the GUI from being loaded.

Is this a new installation of Fedora? Have you tried to change any settings? Were you able to get a graphical display during the installation? Try system-config-display as suggested by Ivan.
Abhiram
Occasional Visitor

Re: runlevel

hi,
its not a new installation & i dint changed any files related to this.

palaniappan.sp
Regular Advisor

Re: runlevel

Hi,
Check the gdm file is created or not in /var/run/gdm
This file will be created automatically only when u configured the X server properly.U can create this file by touch and try to start the init 5.
Pls post the /var/log/messages for further investigation.


Regds
Palani
Everything is Possible and Anything is Feasible if u try
Stuart Browne
Honored Contributor

Re: runlevel

Going to assume it's a RH based system (RedHat, Fedora, CentOS)..

Have you looked to see what errors you're getting in /var/log/Xorg.0.log ? (If you're on an older version, /varl/og/XFree86.0.log)

This should tell you why it can't start the GUI.
One long-haired git at your service...
Jeeshan
Honored Contributor

Re: runlevel

Hi

do you have any hidden file in $HOME directory like .Xautority (may be i can misspelled) file?

If so, delete that file and run the command

#startx
a warrior never quits