System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

running suse linux without nscd

SOLVED
Go to solution
borut kurnik_1
Frequent Advisor

running suse linux without nscd

Hi!

I've got SLES 10 running on DL 580 ProLiant G4 series.

Customer wants me to run the system without nscd(Name Service Caching Daemon). If I stop nscd (also tried to restart the machine), resolving host names stops working. How do I configure resolver libs to work without nscd
on SuSE, as I never had that kinda problem on other linux distributions (debian, redhat, ...).

Thanks,

Borut
6 REPLIES
Stuart Browne
Honored Contributor

Re: running suse linux without nscd

I've never had such an issue either, but my guess is it's related to the contents of '/etc/nsswitch.conf'.

After verifying nsswitch.conf's contents, verify the resolv.conf contents, then stop the daemon (you shouldn't *have* to reboot).

One long-haired git at your service...
borut kurnik_1
Frequent Advisor

Re: running suse linux without nscd

Hi!

Thanks, Stuart.

I know it's awkward, but I never tried to run
suse distro without nscd and it's the same
situation on all suse boxes (SLES, OpenSUSE).

Both files are exactly like on my other machines:

resolv.conf
-----------------------------------------
domain add.local
search add.local
nameserver 172.28.16.50
-----------------------------------------

nsswitch.conf
-----------------------------------------
passwd: compat
group: compat

hosts: files dns
networks: files dns

services: files
protocols: files
rpc: files
ethers: files
netmasks: files
netgroup: files nis
-----------------------------------------




xen1:~ # /etc/init.d/nscd start
Starting Name Service Cache Daemon done
xen1:~ # ping sancho
PING sancho.add.local (172.28.16.20) 56(84) bytes of data.
64 bytes from sancho.add.local (172.28.16.20): icmp_seq=1 ttl=64 time=0.206 ms
64 bytes from sancho.add.local (172.28.16.20): icmp_seq=2 ttl=64 time=0.199 ms

--- sancho.add.local ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.199/0.202/0.206/0.014 ms
xen1:~ # ping sancho.add.local
PING sancho.add.local (172.28.16.20) 56(84) bytes of data.
64 bytes from sancho.add.local (172.28.16.20): icmp_seq=1 ttl=64 time=0.201 ms
64 bytes from sancho.add.local (172.28.16.20): icmp_seq=2 ttl=64 time=0.196 ms

--- sancho.add.local ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.196/0.198/0.201/0.014 ms
xen1:~ # /etc/init.d/nscd stop
Shutting down Name Service Cache Daemon done
xen1:~ # ping sancho

xen1:~ # ping sancho.add.local

Any hints please,

Borut




Stuart Browne
Honored Contributor

Re: running suse linux without nscd

Freaky..

Things to check further..

Firewall: Ensure that UDP 53 can go out and come in to this host from 172.28.16.50. Check the firewall on both 172.28.16.50 and 172.28.16.20.

Hosts file: Does it have an entry for this host, or are you relying upon DNS?

DNS: Do a 'dig' or 'nslookup' for that host, see what results you get.

Random question: Are you using NIS? Your password/group settings in nsswitch.conf suggest you are.

Failing all of this, verify the validity of the libnss* lib's:

ls -l /lib/libnss*

And then run an 'rpm -V glibc' to verify that the lib's themselves haven't been modified.
One long-haired git at your service...
David Kirk_2
Advisor
Solution

Re: running suse linux without nscd

Hey,

I don't know anything about nscd, but I once had a .local domain and when we started using SuSE 9.1 we had problems with name resolution.

I found something in the release notes about SuSE using mDNS (multicast DNS) for name resolution for .local domain names.

The fix at the time was to modify the resolver library like this:

perl -pi -e 's/local/lozal/g' /lib/libresolv.so.2

This replaces all instances of "local" with "lozal".

A quick search turns up this page:

http://www.novell.com/documentation/sled10/readme/release_notes_sp1.html

4.8 Joining a Local Active Directory Domain During Installation

If you want to join a â .localâ Active Directory domain during the SLED 10 SP1 installation, disable the mdns handling by adding mdns off to the /etc/host.conf file.

I don't know if it has been changed in recent versions because we have changed our internal domain name. The easiest way to find out if this is your problem is to run a tcpdump while doing a dns lookup. If it uses port 53 then it is normal DNS. If it is using port 5353 then it is using mDNS.
Ivan Ferreira
Honored Contributor

Re: running suse linux without nscd

Extrange indeed. In /etc/resolv.conf, you have to choose between the "domain" and "search" options. Remove the "domain" line and try again.

What if you try to resolve the hostname using the dig command?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
borut kurnik_1
Frequent Advisor

Re: running suse linux without nscd

Hi!

Sorry guys, been missing for a while...

David, thank you very much. As stupid as
it seems resolver library hates 'local' domain.

Borut