System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

rx2600 primary boot path problem

 
paolo crosara
Occasional Advisor

rx2600 primary boot path problem

I am going to install hp-ux 11.23 on rx2600 integrity server. The EFI auto-install starts correctly and it access the cdrom.
The problem is that it then fails with the error: cannot find the disk referenced by the primary boot path: "" /tmp/hw.info the default chosen for the root disk may not be correct.

I checked /tmp/hw.info file and it really does not have the path. Setboot is empty. It fails with 11.23 versions dated up to 2007. Any idea?
11 REPLIES 11
Sameer_Nirmal
Honored Contributor

Re: rx2600 primary boot path problem

Are you using HyperTerminal or some other Terminal emulator to access the console?

Try using Putty instead with VT100 mode.
paolo crosara
Occasional Advisor

Re: rx2600 primary boot path problem

I have been using hyperterminal. Now I have putty connected to serial and it seems running better.. but the cdrom mapping disappeared... I am still working on
Torsten.
Acclaimed Contributor

Re: rx2600 primary boot path problem

Go to EFI shell and run "map -r", you will find your CD-ROM device.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
paolo crosara
Occasional Advisor

Re: rx2600 primary boot path problem

Already done. The picture it gave me was:

EFI Shell version 1.10 [14.61]

Device mapping table
fs0 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)/HD(Part1,Sig15BB81AC-3601-11DC-8002-D6217B60E588)
fs1 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)/HD(Part3,Sig15BB81E8-3601-11DC-8004-D6217B60E588)
blk0 : Acpi(HWP0002,0)/Pci(2|0)/Ata(Primary,Master)
blk1 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun0,Lun0)
blk2 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)
blk3 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)/HD(Part1,Sig15BB81AC-3601-11DC-8002-D6217B60E588)
blk4 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)/HD(Part2,Sig15BB81CA-3601-11DC-8003-D6217B60E588)
blk5 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)/HD(Part3,Sig15BB81E8-3601-11DC-8004-D6217B60E588)

I believe that blk0 is the one I am looking for. If I try to mount or map blk0 with an alias it will be done successfully but if I submit a command like "ls" it gives me:
Cannot open current directory - No mapping

Note that I rebooted the system or reset it several times and the cdrom media with hp-ux 11.23 is on.

Torsten.
Acclaimed Contributor

Re: rx2600 primary boot path problem

This is the CD-ROM device

blk0 : Acpi(HWP0002,0)/Pci(2|0)/Ata(Primary,Master)


but there is no file system detected.
You should see an fs entry related to this.

Maybe a bad media?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
paolo crosara
Occasional Advisor

Re: rx2600 primary boot path problem

Cdrom media are correct. I used different level of 11.23 and to be sure I tested them on other systems.

Is there a way to manipulate EFI shell or firmware so that it will recognize and mount cdrom ?
Torsten.
Acclaimed Contributor

Re: rx2600 primary boot path problem

It should look like this (taken from a similar system:
(note the fs0: entry)

fs0 : Acpi(HWP0002,PNP0A03,0)/Pci(3|0)/Ata(Primary,Master)/CDROM(Entry0)/HD(P
art1,Sig00000000)


Maybe you have a bad drive or connection.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
paolo crosara
Occasional Advisor

Re: rx2600 primary boot path problem

First time I connected (see above) I detected cdrom and it started automatically the installation of hp-ux. Then the installation failed beacause probably the console was not correct and now with putty it seems ok. But now the problem is that it "sense" the cdrom because it flights at boot time, but I do not know why it does not mount anymore.

Any idea if EFI shell or boot loader may be involved?
Also the command: HPUX> search does not detect the cdrom
Torsten.
Acclaimed Contributor

Re: rx2600 primary boot path problem

Where did you get the

HPUX> search

command on Integrity?
If you are on the hpux> prompt, you are already on a disk.

I have never seen an error message like yours (first post), but I really assume a bad or flaky drive/media/cable because of this behaviour.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Highlighted
paolo crosara
Occasional Advisor

Re: rx2600 primary boot path problem

I do not know. Probably because it started the installation and then failed. Maybe a disk contains something.
How to restart by a clear situation?
Torsten.
Acclaimed Contributor

Re: rx2600 primary boot path problem

If you still have an hp-ux installation on the disk, boot it.
Try to read (dd) the CD.
Mount it, read it to ensure it works first.
Inspect the connection - maybe it is loose.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!