cancel
Showing results for 
Search instead for 
Did you mean: 

samba 2.2.2

 
SOLVED
Go to solution
Super Advisor

samba 2.2.2

Hi experts,
i downloaded samba for hpux11 and installed it on my J200 running hpux11.00.
I configured /etc/services:
swat 901/tcp
and /etc/inetd.conf:
swat stream tcp nowait.400 root /opt/samba/sbin/swat swat
Then i created a script in /sbin/init.d/samba (linked to /sbin/rc2.d/S910Samba) with this entry:
#!/sbin/sh
/opt/samba/sbin/smbd -D /opt/samba/lib/smb.conf
/opt/samba/sbin/nmbd -D /opt/samba/lib/smb.conf
Then i ran ./samba and with ps i saw that daemons are up.
My entry in /opt/samba/lib/smb.conf is:
[global]
guest ok = yes
log file = /var/opt/samba/log.smb
[test]
browseable = yes
read only = no
guest ok = yes
path = /usr2
/usr2 is exported in /etc/exports.
I can also log to my hp by my windows 2000 client with swat. From explorer http://gehp125:901 Everything's seems ok. But while i try to map \\gehp125:\usr2 from map network drive i have:
The mapped network drive could not be created because the following error has occured:
An extended error has occured.
I know that my configuration file isn't secure, i just want to do some tests and see if windows see my hp samba.
Where is my error?
Thanks in advance.
Tarek

13 REPLIES 13
Respected Contributor

Re: samba 2.2.2

Hi,

add to the globals

security = share

And loose the ':'. I mean, you can mount a share like:

//computer/share.

No need for ':'.

E.
To Live Is To Learn
Super Advisor

Re: samba 2.2.2

Eugen, i put security = share in the smb.conf but nothing changed.
Before, talking about map network drive, i made an error typing. Of course i map
\\gehp125\usr2 without : !! ;-)
Any other tip?
Trusted Contributor

Re: samba 2.2.2

The name of your share is "test" and not(!) "usr2".

You have to connect with
\\gehp\test

You should see the "test" share in the network-neighbour-hood.

BTW: there is no need for samba that /usr2 is in /etc/exports. Only NFS uses /etc/exports.
Super Advisor

Re: samba 2.2.2

Not working also with \\gehp180\test
Trusted Contributor

Re: samba 2.2.2

Are there any entries in /var/opt/samba/smb.log?

Do you see a share in the network-neighbour-hood?

Can you resolv the hostname of your samba-server on your windows machine (e.g. try on samba server /opt/samba/bin/nmblookup gehp125)?
Trusted Contributor

Re: samba 2.2.2

If you try to connect using "guest ok=yes" samba connects you to the uid of "nobody" by default.

Do you have the user "nobody" in your passwd?

If not try the global samba option "guest account = ..." to map the samba guest connections to an existing unix uid (e.g. guest).
Super Advisor

Re: samba 2.2.2

In the log.smb file i have this error:
[2001/12/06 14:19:06, 0] lib/util_sec.c:(94)
Failed to set gid privileges to (-1,-2) now set to (0,0) uid=(0,0)
[2001/12/06 14:19:06, 0] lib/util.c:(1055)
PANIC: failed to set gid
nmblookup gehp125:
querying gehp125 on ip_address
ip_address gehp125<00>
so it's OK!
My windows client is able to ping and telnet to my samba server.
Thanks again.
Trusted Contributor

Re: samba 2.2.2

You have the problem with the guest/nobody account!

Use the "guest account= ..." option. (see my earlier posting).
Super Advisor

Re: samba 2.2.2

But i have nobody in my /etc/passwd as follows:
nobody:*:-2:-2::/:
guest account for default is set to nobody.
What user should i put? Do i have to create one?
and with what permissions?