cancel
Showing results for 
Search instead for 
Did you mean: 

sending emails via EVWEB

SOLVED
Go to solution
KPS
Super Advisor

sending emails via EVWEB

We are running HP-UX 11.23 systems and we're trying to setup our systems to send us email notification via evweb for SFM events like EMS used to do. We have built an email alias in /etc/mail/aliases called "root" with the email addresses of server admins who should get notifications when these events are sent to root@localhost. We created our evweb subscription by doing the following:

evweb subscribe -C -n MySubs -t archive -t "email to:root@localhost"

We're testing this out by doing a "sfmconfig -t -a" to see if we get the emails respectively. We're getting email notifications from one out of 5 hosts so far and do not see what's wrong. I've checked /var/adm/syslog/mail.log and don't even see anything attempting to be sent. Could anyone give me some ideas where else I may look?

Thanks
/KPS
5 REPLIES
TTr
Honored Contributor

Re: sending emails via EVWEB

> built an email alias in /etc/mail/aliases called "root"

Why would you create an alias called "root"? What will happen to all that email that root gets from all the running services?

> "email to:root@localhost"
> I've checked /var/adm/syslog/mail.log and don't even see...

If there is nothing in the mail.log file then nothing was submitted to the sendmail daemon to be sent out. How do you know there was an email generated by rge evweb system?
KPS
Super Advisor

Re: sending emails via EVWEB

>Why would you create an alias called "root"? What will happen to all that email that root gets from all the running services?

We want to get events that are being sent to "root" sent to us in an email so we know what's happening on any of our given systems.


We figured out the issue here in why we were not getting the emails. We had sendmail intentionally disabled for security reasons. Once we enable it, the mail is getting to us on these test events using "sfmconfig -t -a". Next, we have to figure out if there's a better solution or another option than just enabling sendmail as that's not too much of something we would like to do just to allow evweb to send emails to us, but it may be our only choice?
KPS
Super Advisor

Re: sending emails via EVWEB

.
kevin_m
Valued Contributor
Solution

Re: sending emails via EVWEB

I ran into exactly the same issue and ended up using the following configuration. My OS is 11.31 but maybe the settings will be useful in your environment.
- Kevin

/etc/rc.config.d/mailservs
export SENDMAIL_SERVER=0
export SENDMAIL_SERVER_NAME=
export SENDMAIL_RECVONLY=0
export SENDMAIL_SENDONLY=1

/etc/mail/sendmail.cf
O DaemonPortOptions=Port=smtp, Addr=127.0.0.1, Name=MTA
KPS
Super Advisor

Re: sending emails via EVWEB

Thanks so much Kevin, appreciate the feedback on this as I have not fully gotten a workaround yet, even though I closed this thread.

Much Appreciate it,

KPS