cancel
Showing results for 
Search instead for 
Did you mean: 

sendmail problem

 
haeman
Frequent Advisor

sendmail problem

I have newly setup a server , and started the sendmail service , I have config the sendmail.cf as below and then restart it

"Smart" relay host (may be null)
DSmail-server


But now still can't sendmail mail out , I have other server that have the same setting can do , so I wonder is there other config file that I need to change to make it work ? please advise thx
5 REPLIES
Ivan Krastev
Honored Contributor

Re: sendmail problem

Check if you relay host is accessible:

telnet relay_host 25


regards,
ivan
Ivan Ferreira
Honored Contributor

Re: sendmail problem

Post the output of /var/log/maillog. Ensure that mail-server can be resolved.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: sendmail problem

Shalom,

In sendmail.cf you should set a relay server

DShostnameofrelayserver

The relay server must be explicitly set up to relay your systems mail.

Most Corporate LAN environments won't let you send mail directly, the spam risk is too high.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Court Campbell
Honored Contributor

Re: sendmail problem

I would suggest installing the sendmail-cf rpm. Then edit the mc file and restart sendmail. This will run m4 for you, etc. This may not resolve your issue, but it is the red hat recommended way of modifying sendmail.
"The difference between me and you? I will read the man page." and "Respect the hat." and "You could just do a search on ITRC, you don't need to start a thread on a topic that's been answered 100 times already." Oh, and "What. no points???"
skt_skt
Honored Contributor

Re: sendmail problem

see if this helps

sendmail.cf file coming with some RH only listens on loopback interface. u can see that in netstat -an

it looks like this

tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN

I Commented following option and restarted the sendmail daemon.

O DaemonPortOptions=Port=smtp,Addr=127.0.0.1, Name=MTA


Then after restarting the daemon using netstat -an.
the output changed to

tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN

My mail now works