HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

sme1 removed /bin and /lib links...

 
SOLVED
Go to solution
chindi
Respected Contributor

sme1 removed /bin and /lib links...

Hi guys,

today morning i was not able to login in my applican , when i chkd i found that /bin/ksh not found...so i checked and found dat softlinks /bin and /lib were missing...
i recreated those links nw everythng is fine...
i would like to know who removed thos e links..
i checked history of each n every user...but could find any rm,cp,mv commnad used...
But what i found in my syslog was some mesg related to hprsmha...given below;


Apr 29 07:00:09 lambodar hprsmha_wd: Gathering up log files
Apr 29 07:00:09 lambodar hprsmha_wd: starting up hprsmha server; restart count: 1
Apr 29 07:00:39 lambodar hprsmha_wd: starting up hprsmha server; restart count: 2
Apr 29 07:01:09 lambodar hprsmha_wd: starting up hprsmha server; restart count: 3
Apr 29 07:01:39 lambodar hprsmha_wd: Reached restart max. Server is not starting up or staying up
Apr 29 07:01:39 lambodar hprsmha_wd: Watchdog exiting.


could dis be the culplrit..who removed those soft links...???
The users history is stored somewhere else and not in itss default path, so there is no question of that user deleting the history...

O.S is hpux 11iv2...model rx2660

Regards,
Chindi
4 REPLIES
Robert-Jan Goossens_1
Honored Contributor
Solution

Re: sme1 removed /bin and /lib links...

Hi Chindi,

You can use following command to restore the links.

# /opt/upgrade/bin/tlinstall -v

I can not find any documents related to hprsmha_wd and removing the links.

Regards,
Robert-Jan

Re: sme1 removed /bin and /lib links...

>I would like to know who removed those links

The simple answer is a system admin removed them.

It is possible if you removed the Upgrade product, it may have removed the tlinks.
chindi
Respected Contributor

Re: sme1 removed /bin and /lib links...

Hi Dennis,

You were spot on...
Afetr a very long investigation i found that a cronjob did it...


Thanx for ur response...

Regards,
chindi

chindi
Respected Contributor

Re: sme1 removed /bin and /lib links...

Cronjob did it...