System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

snmp to be configured in hp ux 11.23

SOLVED
Go to solution
shaikh.imran
Advisor

snmp to be configured in hp ux 11.23

Please help to configure snmp in hp ux 11.23

We will monitor the systems with OV Software.

I checked all the settings and started all the services responsible for snmpd.
And modified the file /etc/snmpd.conf file below....

get-community-name : abcd
max-trap-dest : 150
trap-dest : 50.50.30.56 # IP of the OV Server

...after that I hav also restarted the service...by

#/sbin/init.d/SnmpMaster stop
#/sbin/init.d/SnmpMaster start

...
when I tried to run snmpwalk command in OV server..it shows : No response error.

.Please help me to solve this problem..!!!

Thanks in advance!!!!
4 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: snmp to be configured in hp ux 11.23

Shalom,

Check /var/adm/syslog/syslog.log on the server and see if there is follow up information.

See if there are snmp patches in the patch database at http://itrc.hp.com for snmp patches.

Check the application dvd for updates to snmp.

You could be suffering from a bug, firewall blockage or simple misconfiguration.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
shaikh.imran
Advisor

Re: snmp to be configured in hp ux 11.23

Hi,

Thanks for the responae....

I checked the log but I didnt find the error regarding snmpd..

I found some error in /var/adm/snmpd.log
-----------------------------------------

GetSubagentEvent: setvar not enabled from subagent 5
at line 2635 in file ../master.c
AgentSocketPullInput: short read pending on socket close, data discarded
at line 388 in file ../common.c
-----------------------------------------

...waiting for ur reply!!!
Michael P. O'Brien
Occasional Advisor

Re: snmp to be configured in hp ux 11.23

I had a similar problem that ended up being with the snmpd.conf file. The following was how I was able to arrive at the conclusion to the issue. My network engineer was wanting to set up What's Up Gold in order to monitor NIC card activity and was not able to perform a simple SNMP poll of my HP-UX servers. In order to test for myself I ended up downloading a Windows tool called Getif as it is a free Windows utility. http://www.wtcs.org/snmp4tpc/getif.htm

By using the Getif application I was able to see first hand that I was not able to communicate with the HP-UX servers even though the snmpdm process was running on my servers and I was able to get SNMP information from the local Windows servers as well as our HP printers.

After attempting several changes to the snmpd.conf file and then stopping and restarting the snmpdm process:
/sbin/init.d/SnmpMaster stop
/usr/sbin/snmpd
I was finally able to figure out that the issue was with the format of the snmpd.conf file. I had placed several spaces both in between and prior to the SNMP parameters which evedently caused the SNMP configurations to fail. The best way to get around a situation such as what I experienced is to copy the template file
/usr/newconfig/etc/SnmpAgent.d/snmpd.conf using the "cp -p" in order to keep the same permissions as the exaple provides into the active directory /etc/SnmpAgent.d and then edit the file by simply removing the comments "#" and putting your local information in the place of the template examples. I don't know if that will work for you but, it worked for us.
TroyBlang
Occasional Advisor

Re: snmp to be configured in hp ux 11.23

Hi Michael

 

I have a similar problem as this on HP-UX 11.31 and I am configuring to Whats Up Gold like you did.  I was hoping you could help me out resolve the issue with the timeout between the HP-UX 11.31 server and Whats Up Gold.  Please let me know if you can help me out resolve my issue.

 

Thanks

Troy