cancel
Showing results for 
Search instead for 
Did you mean: 

snmpd logs

SOLVED
Go to solution
Ing Meloni
Advisor

snmpd logs

my /var/log/messages are full of lines like

Jul 28 11:25:51 manager snmpd[3662]: Received SNMP packet(s) from UDP: [127.0.0.1]:52902
Jul 28 11:26:06 manager snmpd[3662]: Connection from UDP: [127.0.0.1]:52906

How do I modify the configuration to avoid these annoying messages to be logged?
I checked the man page, but it is not clear to me how to preserve the important warning to be recorded while avoiding these.

HW: BL460c
SW: Red Hat Enterprise Linux Server release 5.1 kernel 2.6.18-53.el5

Best regards
2 REPLIES
Steven E. Protter
Exalted Contributor

Re: snmpd logs

Shalom,

There should be a log level type configuration available in the snmpd.conf file.

for specifics there is a man page for this conf file.

What version of snmpd are we using here anyway?

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Moreno Daltin
Occasional Visitor
Solution

Re: snmpd logs

You have to replace the line containing the "OPTIONS" variable in

/etc/snmp/snmpd.options

with the following one:

OPTIONS=â -LS 0-4 d -Lf /dev/null -p /var/run/snmpd.pidâ

which stills logs relevant events.