cancel
Showing results for 
Search instead for 
Did you mean: 

sticky bit not getting set

 
SOLVED
Go to solution
skt_skt
Honored Contributor

sticky bit not getting set

HP-UX B.11.11

tnedd13n:root [/var/spool/lp] chmod 1777 class
tnedd13n:root [/var/spool/lp] chmod 1755 cmodel
tnedd13n:root [/var/spool/lp] chmod 1755 fonts
tnedd13n:root [/var/spool/lp] chmod 1777 info
tnedd13n:root [/var/spool/lp] chmod 1777 interface
tnedd13n:root [/var/spool/lp] chmod 1777 log
tnedd13n:root [/var/spool/lp] chmod 1777 lpana.log
tnedd13n:root [/var/spool/lp] chmod 1644 lpd.log
tnedd13n:root [/var/spool/lp] chmod 1755 member
tnedd13n:root [/var/spool/lp] chmod 1555 model

tnedd13n:root [/var/spool/lp] lpsched -a -v
scheduler is running

tnedd13n:root [/var/spool/lp] lpstat -r
scheduler is not running

tnedd13n:root [/var/spool/lp] ll
total 982
lrwxrwxrwx 1 root sys 14 Feb 17 15:38 Tclass -> /etc/lp/Tclass
lrwxrwxrwx 1 root sys 15 Feb 17 15:38 Tmember -> /etc/lp/Tmember
lrwxr-xr-x 1 root sys 18 Feb 17 15:38 cinterface -> /etc/lp/cinterface
lrwxr-xr-x 1 root sys 13 Feb 17 15:38 class -> /etc/lp/class
lrwxr-xr-x 1 root sys 18 Feb 17 15:38 cmodel -> /usr/lib/lp/cmodel
-rwxr-xr-x 1 lp bin 15 Mar 6 2002 default
lrwxr-xr-x 1 root sys 17 Feb 17 15:38 fonts -> /usr/lib/lp/fonts
lrwxr-xr-x 1 root sys 12 Feb 17 15:38 info -> /etc/lp/info
lrwxr-xr-x 1 root sys 17 Feb 17 15:38 interface -> /etc/lp/interface
lrw-r--r-- 1 root sys 15 Feb 17 15:38 log -> /var/adm/lp/log
lrwxrwxrwx 1 root sys 21 Feb 17 15:38 lpana.log -> /var/adm/lp/lpana.log
lrw-r--r-- 1 root sys 19 Feb 17 15:38 lpd.log -> /var/adm/lp/lpd.log
lrwxr-xr-x 1 root sys 14 Feb 17 15:38 member -> /etc/lp/member
lrwxr-xr-x 1 root sys 17 Feb 17 15:38 model -> /usr/lib/lp/model
-rw-r--r-- 1 lp lp 0 Feb 25 13:50 outputq
-rw-r--r-- 1 lp lp 276696 Mar 6 2002 pstatus
-rw-r--r-- 1 lp lp 68808 Mar 6 2002 qstatus
drwxr-xr-x 2 lp bin 96 Nov 15 2000 receive
drwxr-xr-x 392 lp bin 145408 Feb 17 15:38 request
-rwxr-xr-x 1 lp bin 3 Mar 5 2002 seqfile
lrwxr-xr-x 1 root sys 18 Feb 17 15:38 sinterface -> /etc/lp/sinterface
lrwxr-xr-x 1 root sys 18 Feb 17 15:38 smodel -> /usr/lib/lp/smodel


I have a problem starting the spooler and noticed the sticky bit is missing . But the attempt to set the sticky bit is failing w/o any error.

what can cause this ?
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: sticky bit not getting set

Shalom,

You can't set the sticky bit or change ownership on soft links, only the files they actually point to.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
James R. Ferguson
Acclaimed Contributor
Solution

Re: sticky bit not getting set

Hi:

The permissions of a symbolic link or the ownership of a link doesn't matter. Its what it points to that counts.

The "t" you see in this case is really a "t"ransition link which shows the phylogeny of the current HP-UX filesystem layout and its transition that occured with the advent of 10.0.

If you want, you can do:

# tlinstall -v

Regards!

...JRF...

Re: sticky bit not getting set

>I have a problem starting the spooler and noticed the sticky bit is missing.

By fiddling with the permissions and using obsolescent octal values, you have removed the SETUID bits. Instead you should have used u+t.

You will probably have to use "swverify -F" on the spooler components to fix them.