System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

str_mblk_flush_daemon process taking 100% CPU

Abhilash_CMS
Occasional Advisor

str_mblk_flush_daemon process taking 100% CPU

On our production server "str_mblk_flush_daemon" process is taking 100% CPU , any idea why this happens ?

 

It stays like this for long time.

 

Attaching  top output.

 

Thanks 

Abhilash

4 REPLIES

Re: str_mblk_flush_daemon process taking 100% CPU

The daemon is supposed to flush buffers associated with STREAMS (modules used by networking calls) asycnhronously.  

 

The buffers are both per-CPU and global.  Given that you have just 4 cpus on the box, I wouldn't expect the box to have too many of these buffers.  We are most likely looking at some sort of bug, either with STREAMS or with the kernel.

 

Do you see this frequently ? Is it associated usually with heavy networking activity ?

 

What version of the "VM cumulative patch" is installed on the system ?

 

It does look like a bug, so I'd recommend that you file a report and get some of our WTEC/support folks to take a look at the system.

 

-santosh

 


Abhilash_CMS wrote:

On our production server "str_mblk_flush_daemon" process is taking 100% CPU , any idea why this happens ?

 

It stays like this for long time.

 

Attaching  top output.

 

Thanks 

Abhilash


 

Abhilash_CMS
Occasional Advisor

Re: str_mblk_flush_daemon process taking 100% CPU

Thanks Santosh for the reply,

 

Looks like , i am facing the problem after installing "lsof" on the platform and trying to run "lsof"

 

and also "lsof" is not able to show any output and it just hangs. Don't know how to make "lsof" run on the system.

 

Thanks

Abhilash 

Re: str_mblk_flush_daemon process taking 100% CPU

The connection between 'lsof' and STREAMS is not immediately obvious -- perhaps it may trigger networking activity if there are a lot of files open over NFS ?

 

My earlier recommendation of getting support/WTEC involved still stands -- however, if your system is such that you can run some experiments on it, you can try disabling STREAMS caching. [Note that this isn't really recommended, but since you are seeing a problem it may help you workaround the issue]

 

kctune str_mem_cache_enable=0

kctune str_mem_global_cache_disable=0

 

I wouldn't expect a 4-CPU box to show a significant degrade in performance with STREAMS caching disabled.

 

-santosh

Abhilash_CMS
Occasional Advisor

Re: str_mblk_flush_daemon process taking 100% CPU

Thanks Santosh..!!!

I have installed "lsof" on the system to findout the process / appli  which has opened one particular  port.

Do you know any other command on hpux or any other way of finding this ?

 

Thanks 

Abhilash