cancel
Showing results for 
Search instead for 
Did you mean: 

swinstall failure.

 
SOLVED
Go to solution
fizan
Super Advisor

swinstall failure.

* The software "PHKL_31500.CORE2-KRN,r=1.0" has previous
analysis errors.
The prerequisite "PHKL_31500.CORE2-KRN,r=1.0" for fileset
"PHKL_36105.CORE2-KRN,r=1.0" cannot be successfully resolved.
* The software "PHKL_31500.C-INC,r=1.0" has previous analysis
errors.
The corequisite "PHKL_31500.C-INC,r=1.0" for fileset
"PHKL_36105.CORE2-KRN,r=1.0" cannot be successfully resolved.
ERROR: The dependencies for fileset "PHKL_36105.CORE2-KRN,r=1.0"
cannot be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
* The software "PHKL_31500.CORE2-KRN,r=1.0" has previous
analysis errors.
The prerequisite "PHKL_31500.CORE2-KRN,r=1.0" for fileset
"PHKL_36244.CORE2-KRN,r=1.0" cannot be successfully resolved.
ERROR: The dependencies for fileset "PHKL_36244.CORE2-KRN,r=1.0"
cannot be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
* The software "PHKL_31500.LVM-KRN,r=1.0" has previous analysis
errors.
The prerequisite "PHKL_31500.LVM-KRN,r=1.0" for fileset
"PHKL_36244.LVM-KRN,r=1.0" cannot be successfully resolved.
ERROR: The dependencies for fileset "PHKL_36244.LVM-KRN,r=1.0" cannot
be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
* The software "PHKL_31500.CORE2-KRN,r=1.0" has previous
analysis errors.
The prerequisite "PHKL_31500.CORE2-KRN,r=1.0" for fileset
"PHKL_37106.CORE2-KRN,r=1.0" cannot be successfully resolved.
* The software "PHKL_31500.C-INC,r=1.0" has previous analysis
errors.
The corequisite "PHKL_31500.C-INC,r=1.0" for fileset
"PHKL_37106.CORE2-KRN,r=1.0" cannot be successfully resolved.
The corequisite "PHKL_36105.CORE2-KRN,fa=HP-UX_B.11.23_IA |
PHKL_36105.CORE2-KRN,fa=HP-UX_B.11.23_PA" for fileset
"PHKL_37106.CORE2-KRN,r=1.0" cannot be successfully resolved.
The corequisite "PHKL_36105.CORE2-KRN,fa=HP-UX_B.11.23_IA" for
fileset "PHKL_37106.CORE2-KRN,r=1.0" cannot be successfully
resolved.
ERROR: The dependencies for fileset "PHKL_37106.CORE2-KRN,r=1.0"
cannot be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
The corequisite "PHKL_36244.LVM-KRN,fa=HP-UX_B.11.23_IA |
PHKL_36244.LVM-KRN,fa=HP-UX_B.11.23_PA" for fileset
"PHCO_38717.LVM-ENG-A-MAN,r=1.0" cannot be successfully
resolved.
ERROR: The dependencies for fileset "PHCO_38717.LVM-ENG-A-MAN,r=1.0"
cannot be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
* The software "PHKL_31500.LVM-KRN,r=1.0" has previous analysis
errors.
The corequisite "PHKL_31500.LVM-KRN,r=1.0" for fileset
"PHCO_38717.LVM-MIRROR-RUN,r=1.0" cannot be successfully
resolved.
ERROR: The dependencies for fileset "PHCO_38717.LVM-MIRROR-RUN,r=1.0"
cannot be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
* The software "PHKL_31500.C-INC,r=1.0" has previous analysis
errors.
The prerequisite "PHKL_31500.C-INC,r=1.0" for fileset
"PHKL_36103.C-INC,r=1.0" cannot be successfully resolved.
The corequisite "PHKL_36105.CORE2-KRN,fa=HP-UX_B.11.23_IA |
PHKL_36105.CORE2-KRN,fa=HP-UX_B.11.23_PA" for fileset
"PHKL_36103.C-INC,r=1.0" cannot be successfully resolved.
The corequisite "PHKL_37106.CORE2-KRN,fa=HP-UX_B.11.23_IA |
PHKL_37106.CORE2-KRN,fa=HP-UX_B.11.23_PA" for fileset
"PHKL_36103.C-INC,r=1.0" cannot be successfully resolved.
ERROR: The dependencies for fileset "PHKL_36103.C-INC,r=1.0" cannot
be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
1, i have downloaded all patches in single shot as tar file and unshared it and used swinstall -s /home/hp-patches/depot/patches
2 so it entered sam and continued and installed the patches it showed as 100 out 100% completed installation succesfull!!
3 but still my oracle team is unable to install the 10g. so i analysed /var/adm/sw/swagent.log and install.log it shows the above output,

kindly advice how to perform it, i have again reinstalled the swinstall -s /home/hp-patches/depot/patches -x enforce_dependencies=false, it shows another error as:

unable to rebuilt the kernel, how to over come it?
9 REPLIES
fizan
Super Advisor

Re: swinstall failure.

now if i use
swlist

Pthread internal error: message: __pthread_startup() failed , file: /ux/core/libs/threadslibs/src/common/pthreads/pthread.c, line: 8978
Return Pointer is 0xcfc32750
Quit(coredump)

after i again use the swinstall it shows this error now am unable to do even swlist!!
James R. Ferguson
Acclaimed Contributor
Solution

Re: swinstall failure.

HI:

> i have again reinstalled the swinstall -s /home/hp-patches/depot/patches -x enforce_dependencies=false

You virtually never want to skip dependency enforcement during a 'swinstall'. You bypass this requirement when building a software depot to delay dependency checking until the actual analysis phase of 'swinstall'.

If you have an Ignite recovery archive (I hope you do!) then you should probably use it to restore your server to a "sane" state.

Regards!

...JRF...
fizan
Super Advisor

Re: swinstall failure.

so without reinstalling the os i cannot install the softwares right?
James R. Ferguson
Acclaimed Contributor

Re: swinstall failure.

Hi (again):

> so without reinstalling the os i cannot install the softwares right?

I suspect that you have badly damaged things.
After all, you can't even run 'swlist' as you noted without a coredump.

Regards!

...JRF...
Raj D.
Honored Contributor

Re: swinstall failure.

fizan,

>pthread_startup() failed issue:
looks problem with the kernel, after swinstall.

- Try if can rebuilt the kernel from command prompt# mk_kernel -o /stand/vmunix (good vmunix ), and then reboot and check:


- Else :

* restore the system from a backup image tape
* completely reinstall the system from media or ignite




Check this out:
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=718917


hth,
Raj.
" If u think u can , If u think u cannot , - You are always Right . "

Re: swinstall failure.

>Pthread internal error: message: __pthread_startup() failed , file:

Hmm, I thought this error is related to mixing libcma threads with kernel threads. Raj's links seems to be the same error.

Not that this will help you now, can you say what you were patching? From what to what?
Did you already have PHKL_31500 installed?

fizan
Super Advisor

Re: swinstall failure.

no i have installed it for the first time all the patches that time it was not getting installed, so i executed the swinstall with enforce_dependencies=false option and it showed installtion succeded, but after that i came out of sam and tried to do a swlist that time it showed as p_thread error core dump..
Steven E. Protter
Exalted Contributor

Re: swinstall failure.

Shalom,

Never use that option.

What you end up with will be far worse than what you started out with.

Use the patch database to calculate dependencies, or use SWA to get a download with the same thing and install a complete patch set.

If you have installed a patch like this, swremove it and do a complete install with dependencies.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
fizan
Super Advisor

Re: swinstall failure.

i got the solution now i want to swremove and install all again once with correct dependencies!!

thanks!!