cancel
Showing results for 
Search instead for 
Did you mean: 

swremove not working

 
Jayraj
Frequent Advisor

swremove not working

Hi,
I have a package Tripwire in my server I have to remove But when I used swremove Tripwire its not working pls help me..

swlist | grep -i trip
# Initializing...
# Contacting target "chflbm23"...
#
# Target: chflbm23:/
#

# Tripwire 4.0 Tripwire for Servers (HP-UX 11.x)
Tripwire.FILES 4.0 Tripwire for Servers FILES (HP-UX 11.x)


This is the out put of swremove

======= 03/03/09 04:10:15 EST BEGIN swremove SESSION
(non-interactive) (jobid=chflbm23-0143)

* Session started for user "root@chflbm23".

* Beginning Selection
ERROR: RPC exception: "Communications failure (dce / rpc)" 03/03/09
04:10:51 EST
ERROR: A Remote Procedure Call to a daemon has failed. Could not
start a management session for "chflbm23:/". Make sure the
host is accessible from the network, and that its daemon,
swagentd, is running.
* Target connection failed for "chflbm23:/".
ERROR: More information may be found in the daemon logfile on this
target (default location is
chflbm23:/var/adm/sw/swagentd.log).
* Selection had errors.



======= 03/03/09 04:10:51 EST END swremove SESSION (non-interactive)
(jobid=chflbm23-0143)
17 REPLIES
Avinash20
Honored Contributor

Re: swremove not working

Do a

# swagentd -r

and then check

Also check that the nslookup to the host works fine

# nslookup chflbm23

Also in /etc/nsswitch.conf file entry should be files first

hosts: files dns

If nsswitch.conf files does not exist, copy it from

# cp /etc/nsswitch.files /etc/nsswitch.conf
# swagentd -r

Please assign points
"Light travels faster than sound. That's why some people appear bright until you hear them speak."

Re: swremove not working

first thing to try would be to restart swagentd and then try again:

swagentd -r


Also look in the mentioned log:

/var/adm/sw/swagentd.log

HTH

Duncan

HTH

Duncan
Sridhar R
Regular Advisor

Re: swremove not working

Hi Swaraj,

Did you check the /etc/hosts entry of your server.

Try restarting the swagentd daemon and execute swremove again.

Thanks & Regards
Sridhar
Jayraj
Frequent Advisor

Re: swremove not working

Thank you for quick responce..
Hi have restarted the deamon
#

Here is the output of /etc/nsswitch.conf file
# cat /etc/nsswitch.conf
hosts: files [NOTFOUND=continue UNAVAIL=continue TRYAGAIN=continue] dns [NOTFOUND=return UNAVAIL=continue TRYAGAIN=return]



However still I am unable to remove
#swremove Tripwire

# swremove Tripwire

======= 03/03/09 04:26:31 EST BEGIN swremove SESSION
(non-interactive) (jobid=chflbm23-0145)

* Session started for user "root@chflbm23".

* Beginning Selection
ERROR: RPC exception: "Communications failure (dce / rpc)" 03/03/09
04:27:06 EST
ERROR: A Remote Procedure Call to a daemon has failed. Could not
start a management session for "chflbm23:/". Make sure the
host is accessible from the network, and that its daemon,
swagentd, is running.
* Target connection failed for "chflbm23:/".
ERROR: More information may be found in the daemon logfile on this
target (default location is
chflbm23:/var/adm/sw/swagentd.log).
* Selection had errors.



======= 03/03/09 04:27:06 EST END swremove SESSION (non-interactive)
(jobid=chflbm23-0145)
Jayraj
Frequent Advisor

Re: swremove not working

This is the entry in etc/hosts

153.6.112.16 chflbm23 ch-flor-bm23
Avinash20
Honored Contributor

Re: swremove not working

# nslookup chflbm23
# netstat -in

Does chflbm23 resolve to the IP address
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Jayraj
Frequent Advisor

Re: swremove not working

Hi here is the nslookup and netstat -in outputs

nslookup

Using /etc/hosts on: chflbm23

looking up FILES
Name: chflbm23
Address: 153.6.112.16
Aliases: ch-flor-bm23


#netstat -in

# netstat -in
Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll
lan0 1500 153.6.112.0 153.6.112.16 4072271 0 624842 0 0
lo0 4136 127.0.0.0 127.0.0.1 10285 0 10285 0 0
Avinash20
Honored Contributor

Re: swremove not working

Hi,

Please post the output of

# nslookup chflbm23
# nslookup
# hostname
# netstat -in

Thanks
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Jayraj
Frequent Advisor

Re: swremove not working

Hi here is the other two outputs
# nslookup 153.6.112.16
Using /etc/hosts on: chflbm23

looking up FILES
Name: chflbm23
Address: 153.6.112.16
Aliases: ch-flor-bm23


# hostname
chflbm23
Avinash20
Honored Contributor

Re: swremove not working

netstat -in

Ist line output with the IP address.
I am asking since wanted to confirm if that IP address resolves to the same host,
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: swremove not working

Also could you post the swagent.log and swagentd.log (/var/adm/sw)
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: swremove not working

Also note that

ifconfig lan0' and '/etc/hosts' IP's description are same.
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Jayraj
Frequent Advisor

Re: swremove not working

Hi..
I think swagentd is not getting stopped
when I used sbin/init.d/swagentd stop
it is giving that deamon has stopped
However it still there..

# ps -ef | grep -i swagent*
root 9507 1 0 04:24:00 ? 0:00 swagentd -r
root 12489 7913 0 05:02:02 pts/4 0:00 grep -i swagent*
Avinash20
Honored Contributor

Re: swremove not working

# /usr/sbin/swagentd -k
# ps -ef| grep swagentd
# /usr/sbin/swagentd
# ps -ef| grep swagentd
root 9112 1 0 21:03:11 ? 0:00 /usr/sbin/swagentd


Could you answers the above reply please
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: swremove not working

Post the last few lines of the swagent.log and swagentd.log (/var/adm/sw)
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Jayraj
Frequent Advisor

Re: swremove not working

hi swagent is ok now.. so wt info should I give...
Avinash20
Honored Contributor

Re: swremove not working

LAst 100 lines of

tail -n 100

/var/adm/sw/swagent.log
/var/adm/sw/swagentd.log
"Light travels faster than sound. That's why some people appear bright until you hear them speak."